Project

General

Profile

Actions

Bug #2540

closed

Table entries added by filterdns can clobber overlapping hardcoded entries during DNS changes

Added by Jim Pingle over 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Rules / NAT
Target version:
Start date:
07/05/2012
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

If filterdns resolves a record to an IP that exists in a table, and then later switches away, the hardcoded IP will be lost.

A practical example, have an alias with this:
1.2.3.4
myhost.dyndns.org

Initially, myhost.dyndns.org would resolve to something else, say 5.6.7.8. The table now contains:
1.2.3.4
5.6.7.8

Then the myhost.dyndns.org user visits the site with 1.2.3.4, which filterdns picks up. The table now contains:
1.2.3.4

The myhost.dyndns.org user leaves again, and myhost.dyndns.org resolves to 5.6.7.8. The table now contains:
5.6.7.8

The original hardcoded 1.2.3.4 is lost because filterdns removed it during the last switch.

Actions #1

Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback
Actions #2

Updated by Ermal Luçi almost 9 years ago

  • % Done changed from 0 to 100

Applied in changeset pfsense-tools:commit:6f436e9ddf46e64e9b6d87d587a63242b4063d0d.

Actions #3

Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

confirmed fixed. and the other filterdns issues we've been discussing the last few days are fixed too now Ermal.

Actions

Also available in: Atom PDF