Project

General

Profile

Bug #255

Any interfaces that shows IP should include/exclude the ip-aliases

Added by Ker Ruben Ramos over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Interfaces
Target version:
Start date:
12/29/2009
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Almost everywhere, when showing the Interface's IP which has aliases, shows only the NIC's IP or even worse shows only one of its ip-alias(probably the last one that shows on ifconfig).

I suggest it shows only the actual IP. If needed fix the ip-alias bug or show the ip-aliases like

IP: 192.168.1.1 { 192.168.1.2, 192.168.1.3, ... }

The one I noticed is the "Interfaces" list.

config-test-20100221163943.xml (18.1 KB) config-test-20100221163943.xml Chris Buechler, 02/21/2010 04:43 PM

Associated revisions

Revision b8e3b043 (diff)
Added by Ermal Luçi over 9 years ago

Ticket #255. Activate pfSense module to get the helper functions.

Revision 3f70e618 (diff)
Added by Ermal Luçi over 9 years ago

Ticket #255. Return only ip address not aliases. Also improve speed by using pfSense php module call.

Revision cb074893 (diff)
Added by Ermal Luçi about 9 years ago

Ticket #255. Fix get_interface_info output to return propper ip address by using pfSense_get_interface_addresses function.

History

#1 Updated by Ermal Luçi over 9 years ago

Solution implemented in pfSense php module.
It will be included as soon as some builder issues regarding that module are fixed.

#2 Updated by Ermal Luçi over 9 years ago

  • Status changed from New to Feedback

#3 Updated by Chris Buechler about 9 years ago

This is worse now than it was before. On snapshot Sat Feb 20 09:38:01 EST 2010, with two IP aliases on LAN, the WAN shows its IP as one of the LAN aliases, the LAN shows its IP as one of the LAN aliases. Config example attached. Ermal, you can see this live on 10.0.64.29.

#4 Updated by Ermal Luçi about 9 years ago

This has nothing to do with the pfSense module.
Since get_interface_info does not use it i will fix it eventually to use that module.

#5 Updated by Ermal Luçi about 9 years ago

  • Status changed from New to Feedback

Patch committed.

#6 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF