Project

General

Profile

Bug #270

Error when enabling captive portal

Added by Abdsalem Chaoui over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Captive Portal
Target version:
Start date:
01/04/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

2.0-BETA1 built on Sun Jan 3 22:19:08 EST 2010

When I enable captive portal the following shows up in the system log...

Jan 4 10:50:23 php: /services_captiveportal.php: The command '/usr/local/sbin/lighttpd -f /var/etc/lighty-CaptivePortal.conf' returned exit code '255', the output was '2010-01-04 10:50:23: (network.c.345) can't bind to port: 80 Address already in use'

I think this is caused by the new https redirect in /etc/inc/system.inc, lines 1027~1034.

The error does not occur when webConfigurator protocol is set to http.

Thanks

Slam

Associated revisions

Revision a978a0ff (diff)
Added by Chris Buechler over 10 years ago

unbreak CP after HTTP > HTTPS redirect

Ticket #270

History

#1 Updated by Chris Buechler over 10 years ago

  • Status changed from New to Resolved

fixed, thanks

Also available in: Atom PDF