Project

General

Profile

Actions

Bug #2789

closed

Bug with DHCPD, with the last upgrade from 2.1

Added by Moula BADJI almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Category:
DHCP (IPv4)
Target version:
Start date:
02/01/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

DHCPD don't start. It try to start it but it not possible. tank's

Message : Disabling DHCPD...pgrep: Invalid pid in file '/var/dhcpd/var/run/dhcpd.pid'

Actions #1

Updated by Renato Botelho almost 9 years ago

Could you please post here the content of /var/dhcpd/var/run/dhcpd.pid?

Actions #2

Updated by Renato Botelho almost 9 years ago

  • Status changed from New to Feedback
Actions #3

Updated by Moula BADJI almost 9 years ago

vi /var/dhcpd/var/run/dhcpd.pid :

ov-uu4

thank's

Actions #4

Updated by Renato Botelho almost 9 years ago

That is something really strange since dhcpd is the responsible to sabe pid there.

Could you please try to kill any dhcpd process that is running, then remove /var/dhcpd/var/run/dhcpd.pid and try again?

Actions #5

Updated by Renato Botelho almost 9 years ago

  • Assignee set to Renato Botelho
Actions #6

Updated by Moula BADJI almost 9 years ago

Hello,
Ihave the same problème .

Do you want to enable the DHCP server on LAN? [y|n] y
Enter the start address of the IPv4 client address range: 192.168.100.150
Enter the end address of the IPv4 client address range: 192.168.100.250
Disabling DHCPD...pgrep: Invalid pid in file `/var/dhcpd/var/run/dhcpd.pid'
Done!

Please wait while the changes are saved to LAN... Reloading filter...
DHCPD...pgrep: Invalid pid in file `/var/dhcpd/var/run/dhcpd.pid'

The IPv4 LAN address has been set to 192.168.100.252/24
You can now access the webConfigurator by opening the following URL in your web browser:
http://192.168.100.252/

Press <ENTER> to continue.

Thank's

Actions #7

Updated by Renato Botelho almost 9 years ago

Are you using a recent snapshot?
Does this problem happen only when you configure it or during the boot too?
Is dhcpd running after the error happen?
Is there error messages on /var/log/dhcpd.log?

Actions #8

Updated by Renato Botelho almost 9 years ago

  • Status changed from Feedback to Closed

It's not reproducible, seems to be a local issue instead of a bug on pfSense. Please try to find help in forums and/or mailing lists.

Actions

Also available in: Atom PDF