Project

General

Profile

Actions

Bug #296

closed

VLAN trunking on LAGG doesn't work with em(4)

Added by Perry Mason almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
Start date:
01/14/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

Tried adding a vlan to lagg using 2 intel giga nic's without success as posted in
http://forum.pfsense.org/index.php/topic,21642.0.html
I notice in console that lagg ain't shown as a valid interface under assign interface

Actions #1

Updated by Ermal Luçi almost 12 years ago

  • Status changed from New to Feedback
Actions #2

Updated by Ermal Luçi almost 12 years ago

Can you try with another card?
It seems to behave ok to me.

Actions #3

Updated by Perry Mason almost 12 years ago

Nope only got intel nic that works with pfSense.

Actions #4

Updated by Ermal Luçi almost 12 years ago

Try creating the vlans over lagg and after that assign even the lagg interface and add a firewall rule to allow traffic.
Does this solve the problem for you?

Actions #5

Updated by Marcus van Dam almost 12 years ago

Im the original topic starter on th forum.
I ahve tested with 2 intel nics (more precise, its an dual nic card). I did some testes and the results were:
2 nics -> lagg, no vlan: works.
2 nics -> lagg, adding an vlan: No traffic over the vlan, traffic over the parent lagg interface works.
2 nics -> lagg, only vlans: No traffic over the vlans, but arp requests work.

Actions #6

Updated by Chris Buechler almost 12 years ago

  • Subject changed from VLAN on LAGG to VLAN trunking on LAGG doesn't work with em(4)
  • Category changed from Interfaces to Operating System
  • Status changed from Feedback to New

Confirmed it works with non-em NICs. The underlying configuration is correct, problem in em driver.

Actions #7

Updated by Ermal Luçi almost 12 years ago

  • Status changed from New to Feedback

Can you please try newer pfSense 2.0 builds.
It should be fixed by the jump to 8-STABLE as FreeBSD code base.

Actions #8

Updated by Marcus van Dam almost 12 years ago

I just tried with the latest snapshot (pfSense-Full-Update-2.0-BETA1-20100125-2045.tgz).
It still hangs when assigning the interface, but at reboot it shows up. and i can configure it. after that still only arp packets, a ping won't come trough.

Actions #9

Updated by Ermal Luçi almost 12 years ago

Patch committed to the build because this is a FreeBSD issue.
Report back...after a new build is available.

Actions #10

Updated by Marcus van Dam almost 12 years ago

Ermal Luçi wrote:

Patch committed to the build because this is a FreeBSD issue.
Report back...after a new build is available.

How do you mean a new build? a new FreebSD build as in 8_1 or just a new snapshot? Or just give me a nudge when u can try again :-)

Actions #11

Updated by Ermal Luçi almost 12 years ago

Try with the latest snaps.

Actions #12

Updated by Marcus van Dam almost 12 years ago

I think i have to congratulate you!
It Works! :-)

But, how did you fix it/Where was the problem?

Actions #13

Updated by Perry Mason almost 12 years ago

Could also create a working failover link with em nics, though a reboot was needed.

Actions #14

Updated by Ermal Luçi almost 12 years ago

This are the relevant commits
65ba850791ca318786fb36f0a42274ff7a83af4a
ac1dbfbd79d2489220ff0531f614250f55940176
64fd5b02c883db52511a333d8b879eaad2038d11

Actions #15

Updated by Chris Buechler almost 12 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF