Project

General

Profile

Actions

Bug #2982

closed

Default gateway gone when WAN is unplugged then plugged

Added by Phillip Davis over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Routing
Target version:
Start date:
05/07/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

When I disconnect the WAN cable to the internet, the default route disappears (that is OK - the WAN is down!).
When I connect the WAN cable again, all the stuff that uses WAN explicitly (OpenVPN...) starts fine (does not need a default route), but the default route never appears in the routing table.
I have had a few reports of this. Had one yesterday on 2.1-BETA1 (i386) built on Fri Apr 5 00:57:50 EDT 2013, Alix nanoBSD with single WAN (static public IP) and local subnets on LAN and OPT1. Tried it on my test system just now - 2.1-BETA1 (i386) built on Sun May 5 07:29:11 EDT 2013 with WAN (static private IP behind other stuff) and OPT1 as 2 internet connections, LAN and WiFi as local subnets, and had the same problem.
I can reproduce it easily. The system log does not have anything that looks like an error adding a route to the routing table. Maybe the place in the code where it should be putting back the default route is simply not getting executed?
To get the default route back, I edit and save the WANGW.
Is this really such an easy problem to reproduce? I am surprised that others are not also reporting it.


Files

DefaultRouteGone.png (15.4 KB) DefaultRouteGone.png Phillip Davis, 05/07/2013 02:29 AM
Actions #1

Updated by Phillip Davis over 8 years ago

This should be have been fixed by pull request https://github.com/pfsense/pfsense/pull/626
Once it is out and tested a bit in upcoming snapshots, this bug report can be closed.

Actions #2

Updated by Chris Buechler over 8 years ago

  • Status changed from New to Feedback
Actions #3

Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

confirmed fixed

Actions

Also available in: Atom PDF