Project

General

Profile

Bug #304

Deleting a static gateway results in an auto-added dynamic gateway

Added by Chris Buechler over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Gateways
Target version:
Start date:
01/16/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When you have a static gateway configured, and delete that gateway, you end up with an auto-added dynamic gateway for that interface.

To replicate:
Configure OPT1 as static, with a static gateway.
Delete the gateway on system_gateways.php
Upon page refresh of system_gateways.php you have a dynamic gateway for OPT1, though Interfaces > OPT1 shows no gateway configured (which is correct).

config-redmine304.xml (13.6 KB) config-redmine304.xml Chris Buechler, 02/14/2010 01:52 AM

Associated revisions

Revision 83f9c8ee (diff)
Added by Ermal Luçi over 9 years ago

Ticket #304. Fix bogus dynamic entries in system->gateways after deleting gateways.

Revision 9c6db17a (diff)
Added by Ermal Luçi over 9 years ago

Remove the gateway even from the interface if it is used by it. Resolves #304.

History

#1 Updated by Ermal Luçi over 9 years ago

  • Status changed from New to Feedback

I cannot reproduce this.
Can you send me your config?

#2 Updated by igor igor over 9 years ago

I'm having the same error:

<gateways>
<gateway_item>
<interface>lan</interface>
<name>LAN</name>
<gateway>10.0.0.1</gateway>
<descr>Interface LAN static Gateway</descr>
<monitor>10.0.0.1</monitor>
</gateway_item>
<gateway_item>
<gateway>dynamic</gateway>
<descr>Interface WAN dynamic Gateway</descr>
<name>WAN</name>
<interface>wan</interface>
<defaultgw/>
</gateway_item>
</gateways>

When I try to edit the dynamic gateway I get this on save:

The following input errors were detected:
The field 'Gateway' is required.

#3 Updated by Ermal Luçi over 9 years ago

Try later snapshots.
I committed a fix.

#4 Updated by Chris Buechler over 9 years ago

Still a bit of a problem here. For example, restore the attached config, browse to System > Gateways. Delete OPT1GW and you end up with a dynamic OPT1 gateway. After applying changes it goes away, but it shouldn't ever be shown.

#5 Updated by Ermal Luçi over 9 years ago

  • Status changed from New to Feedback

#6 Updated by Chris Buechler over 9 years ago

  • Status changed from Feedback to New

This has regressed since my last update. At that point, it only showed the dynamic gateway until changes were applied. Now it has a dynamic gateway that doesn't go away.

#7 Updated by Ermal Luçi over 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#8 Updated by Chris Buechler over 9 years ago

  • Status changed from Resolved to Feedback

needs testing

#9 Updated by Chris Buechler over 9 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF