Project

General

Profile

Actions

Bug #3104

closed

Upgrade 2.1RC0 code breaks RRD databases on nano

Added by Anonymous over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
RRD Graphs
Target version:
Start date:
07/23/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

After upgrading to 2.1-RC0 (i386) built on Tue Jul 23 09:56:03 EDT 2013 I noticed that my RRD traffic graphs are failing to generate on my Alix system. Not sure which snapshot broke it since I have updated multiple times this week and didn't notice until now.

Version 2.1-RC0 (i386)
built on Tue Jul 23 09:56:03 EDT 2013

Platform nanobsd (2g)
CPU Type Geode(TM) Integrated Processor by AMD PCS

/status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: No DS called 'inpass6' in '/var/db/rrd/wan-traffic.rrd'/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/wan-traffic.rrd-month.png --start 1371957483 --end 1374635883 --step 3600 --vertical-label "bits/sec" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "`hostname` - WAN :: Traffic - 1 month - 1 hour average" --height 200 --width 620 DEF:wan-in_bytes_pass=/var/db/rrd/wan-traffic.rrd:inpass:AVERAGE:step=3600 DEF:wan-out_bytes_pass=/var/db/rrd/wan-traffic.rrd:outpass:AVERAGE:step=3600 DEF:wan-in_bytes_block=/var/db/rrd/wan-traffic.rrd:inblock:AVERAGE:step=3600 DEF:wan-out_bytes_block=/var/db/rrd/wan-traffic.rrd:outblock:AVERAGE:step=3600 DEF:wan-in6_bytes_pass=/var/db/rrd/wan-traffic.rrd:inpass6:AVERAGE:step=3600 DEF:wan-out6_bytes_pass=/var/db/rrd/wan-traffic.rrd:outpass6:AVERAGE:step=3600 DEF:wan-in6_bytes_block=/var/db/rrd/wan-traffic.rrd:inblock6:AVERAGE:step=3600 DEF:wan-out6_bytes_bl


Files

Untitled.tiff (133 KB) Untitled.tiff Anonymous, 07/23/2013 10:25 PM
Actions #1

Updated by Jeremy L over 8 years ago

This also happened to me when upgrading from the latest stable 2.0 release to 2.1-RC1. The 2.1 build used for the upgrade was from Aug 17 2013:

built on Sat Aug 17 21:32:40 EDT 2013 
FreeBSD xxx 8.3-RELEASE-p9 FreeBSD 8.3-RELEASE-p9 #0: Sat Aug 17 23:04:33 EDT 2013 root@snapshots-8_3-i386.builders.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense_wrap_vga.8.i386 i386
nanobsd     (4g)
Actions #2

Updated by Jeremy L over 8 years ago

Here are some related tickets which were perhaps closed prematurely:
Issue #2651
Issue #2159

Please let me know if I can submit any log or debug information to help with this issue.

Actions #3

Updated by Renato Botelho over 8 years ago

  • Status changed from New to Feedback

The error message "No DS called 'inpass6'" means the database was not converted to new format, what happens when config is updated from version 8.0 to version 8.1. I did a good number of updates from 2.0.3 to 2.1-RC1 last days and could not reproduce the issue.

Could you share a copy of your 2.0 config.xml (removing sensitive data) containing rrd data with me? You can send me it privately if you want, just send an email to , and I'll try to reproduce the issue here.

Actions #4

Updated by Chris Buechler about 8 years ago

  • Status changed from Feedback to Closed

duplicate of #2159

Actions

Also available in: Atom PDF