Project

General

Profile

Actions

Bug #3200

closed

IPv6 bugs

Added by Wouter Snels about 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
09/15/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1-IPv6
Affected Architecture:
i386

Description

The Board is alix2d13

uname -a
FreeBSD xxx.xxx.xxx.xxxxx.net 8.3-RELEASE-p10 FreeBSD 8.3-RELEASE-p10 #0: Sun Sep  8 20:52:15 EDT 26

  • vr2 v6 is not dhcp it has a dhcp running, but it didn't get that ip prefix through dhcp, not sure if that's what it means, .. but if this isn't a bug then there's a bug in the ipv4 cause it is also running an dhcp and it isn't showing
  • pppoe0 has an IPv6 as you can see in ifconfig pppoe0, but it doesn't show this doesn't show in the web interface either, note screenshot attachment.
  • Even though the ipv6 is there and routing is done through openbgpd, it doesn't seem to work the dhcp6c starts several times but something is wrong with it sh & php also open port 546 and keep crashing, cause they appear and disappear when doing sockstat -46lp546, .. killall dhcp6c and running /usr/local/sbin/dhcp6c -f -d -D -c /var/etc/dhcp6c_wan.conf -p /var/run/dhcp6c_pppoe0.pid pppoe0 makes it work, so why is it this doesn't work by it self why do i need to interfere.
 WAN (wan)       -> pppoe0     -> v4/PPPoE: 213.219.170.xxx/32
 LAN (lan)       -> vr2        -> v4: 212.71.19.xx/28
                                  v6/DHCP6: 2a02:578:xxxx::1/48
: ifconfig pppoe0
pppoe0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> metric 0 mtu 1492
        inet6 fe80::20d:b9ff:fe2b:7f76%pppoe0 prefixlen 64 scopeid 0xb 
        inet 213.219.170.xxx --> 213.219.132.xx netmask 0xffffffff 
        inet6 2a02:578:8401:1500:20d:b9ff:fe2b:xxxx prefixlen 64 autoconf 
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>

Files

screenshot.jpg (21.1 KB) screenshot.jpg Wouter Snels, 09/15/2013 06:01 AM
Actions #1

Updated by Chris Buechler almost 8 years ago

  • Status changed from New to Feedback

the third bullet point is the same cause as #3394. The fix for that might fix everything else you've noted here. Can you please retry with 2.1.1 via snapshots.pfsense.org and let us know if you can still replicate any of this?

Actions #2

Updated by Chris Buechler over 7 years ago

  • Status changed from Feedback to Closed

no feedback, I've confirmed elsewhere what I believe to be the root cause of the described problem to be fixed in 2.1.1.

Actions #3

Updated by Anonymous over 7 years ago

I can confirm that at least the 2nd bullet point is still valid with the latest snapshot of 2.1.1.

2.1.1-PRERELEASE (amd64)
built on Fri Feb 28 09:36:05 EST 2014
FreeBSD 8.3-RELEASE-p14
Actions #4

Updated by Kevin Bäker over 7 years ago

The second point is still open to me.

2.1.1-PRERELEASE (i386) 
built on Fri Mar 14 08:27:57 EDT 2014 
FreeBSD 8.3-RELEASE-p14
WAN (wan)       -> pppoe0      -> v4/PPPoE: 193.159.xxx.xxx/32
LAN (lan)       -> vr0_vlan101 -> v4: 192.168.125.1/24
                                  v6/t6: 2003:75:4f6a::4bf0/64
pppoe0: flags=88d1<UP,POINTOPOINT,RUNNING,NOARP,SIMPLEX,MULTICAST> metric 0 mtu 1492
        inet6 fe80::4bf2%pppoe0 prefixlen 64 scopeid 0xb
        inet6 2003:75:4f7f::4bf2 prefixlen 64 autoconf
        inet 193.159.xxx.xxx --> 217.0.xxx.xxx netmask 0xffffffff
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
Actions #5

Updated by Wouter Snels over 7 years ago

It is still valid

FreeBSD x.net 8.3-RELEASE-p14 FreeBSD 8.3-RELEASE-p14 #0: Wed Mar 19 16:25:32 EDT 2014  6

Actually it got worse after I setup pppoe for wan I manualy had to select which interface it should use.

And native IPv6 still doesn't work at all

LAN to WAN

: ping6 -n -c 1 -S 2a02:578:x::1 2a02:578:8401:1500:20d:b9ff:fe2e:x 
PING6(56=40+8+8 bytes) 2a02:578:x::1 --> 2a02:578:8401:1500:20d:b9ff:fe2e:x
16 bytes from 2a02:578:8401:1500:20d:b9ff:fe2e:x, icmp_seq=0 hlim=64 time=0.470 ms

--- 2a02:578:8401:1500:20d:b9ff:fe2e:x ping6 statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 0.470/0.470/0.470/0.000 ms

WAN to LAN
: ping6 -n -c 1 -S 2a02:578:8401:1500:20d:b9ff:fe2e:x 2a02:578:x::1
PING6(56=40+8+8 bytes) 2a02:578:8401:1500:20d:b9ff:fe2e:x --> 2a02:578:x::1
16 bytes from 2a02:578:x::1, icmp_seq=0 hlim=64 time=0.466 ms

--- 2a02:578:x::1 ping6 statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 0.466/0.466/0.466/0.000 ms

WAN to SERVER
: ping6 -n -c 1 -S 2a02:578:8401:1500:20d:b9ff:fe2e:x 2a02:578:x:1::1
PING6(56=40+8+8 bytes) 2a02:578:8401:1500:20d:b9ff:fe2e:x --> 2a02:578:x:1::1
16 bytes from 2a02:578:x:1::1, icmp_seq=0 hlim=59 time=11.854 ms

--- 2a02:578:x:1::1 ping6 statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 51.815/51.815/51.815/0.000 ms

WAN to GOOGLE
: ping6 -n -c 1 -S 2a02:578:8401:1500:20d:b9ff:fe2e:x google.be
PING6(56=40+8+8 bytes) 2a02:578:8401:1500:20d:b9ff:fe2e:x --> 2a00:1450:400c:c06::5e
16 bytes from 2a00:1450:400c:c06::5e, icmp_seq=0 hlim=56 time=15.397 ms

--- google.be ping6 statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 15.397/15.397/15.397/0.000 ms

LAN to GOOGLE
: ping6 -n -c 1 -S 2a02:578:x::1 google.be
PING6(56=40+8+8 bytes) 2a02:578:x::1 --> 2a00:1450:400c:c06::5e

--- google.be ping6 statistics ---
1 packets transmitted, 0 packets received, 100.0% packet loss

ROUTE FOR LAN
: route -n get -inet6 2a02:578:x::1
   route to: 2a02:578:x::1
destination: 2a02:578:x::1
  interface: lo0
      flags: <UP,HOST,DONE,STATIC>
 recvpipe  sendpipe  ssthresh  rtt,msec    mtu        weight    expire
       0         0         0         0     16384         1         0

ROUTE FOR WAN
: route -n get -inet6 2a02:578:8401:1500:20d:b9ff:fe2e:x
   route to: 2a02:578:8401:1500:20d:b9ff:fe2e:x
destination: 2a02:578:8401:1500:20d:b9ff:fe2e:x
  interface: lo0
      flags: <UP,HOST,DONE,STATIC>
 recvpipe  sendpipe  ssthresh  rtt,msec    mtu        weight    expire
       0         0         0         0     16384         1         0

Actions #6

Updated by Wouter Snels over 7 years ago

*** Welcome to pfSense 2.1.1-PRERELEASE-nanobsd (i386) on wan.rte.edp ***

 WAN (wan)       -> pppoe0     -> v4/PPPoE: 213.219.170.x/32
 LAN (lan)       -> vr2        -> v4: 212.71.19.x/28
                                  v6/DHCP6: 2a02:578:x::1/48

 0) Logout (SSH only)                  8) Shell
 1) Assign Interfaces                  9) pfTop
 2) Set interface(s) IP address       10) Filter Logs
 3) Reset webConfigurator password    11) Restart webConfigurator
 4) Reset to factory defaults         12) pfSense Developer Shell
 5) Reboot system                     13) Upgrade from console
 6) Halt system                       14) Enable Secure Shell (sshd)
 7) Ping host                         15) Restore recent configuration

Enter an option:

nothing has been fixed btw, .. the problem is still there, LAN is assigned statistically and pppoe has a dynamic ipv6 which doesn't show at all.
Actions #7

Updated by Wouter Snels over 7 years ago

Maybe this is usefull..

: netstat -rn -f inet6 
Routing tables

Internet6:
Destination                       Gateway                       Flags      Netif Expire
default                           fe80::207:7dff:fe56:5900%pppoe0 UGS      pppoe0
::1                               ::1                           UH          lo0
2a02:578:x::/48                   link#3                        U           vr2
2a02:578:x::1                     link#3                        UHS         lo0
2a02:578:8401:1500::/64           link#8                        U        pppoe0
2a02:578:8401:1500:20d:b9ff:fe2e:xc6 link#8                     UHS         lo0
fe80::%vr0/64                     link#1                        U           vr0
fe80::20d:b9ff:fe2e:xc4%vr0       link#1                        UHS         lo0
fe80::%vr2/64                     link#3                        U           vr2
fe80::20d:b9ff:fe2e:xc6%vr2       link#3                        UHS         lo0
fe80::%lo0/64                     link#7                        U           lo0
fe80::1%lo0                       link#7                        UHS         lo0
fe80::%pppoe0/64                  link#8                        U        pppoe0
fe80::20d:b9ff:fe2e:xc6%pppoe0    link#8                        UHS         lo0
ff01::%vr0/32                     fe80::20d:b9ff:fe2e:xc4%vr0   U           vr0
ff01::%vr2/32                     fe80::20d:b9ff:fe2e:xc6%vr2   U           vr2
ff01::%lo0/32                     ::1                           U           lo0
ff01::%pppoe0/32                  fe80::20d:b9ff:fe2e:xc6%pppoe0 U        pppoe0
ff02::%vr0/32                     fe80::20d:b9ff:fe2e:xc4%vr0   U           vr0
ff02::%vr2/32                     fe80::20d:b9ff:fe2e:xc6%vr2   U           vr2
ff02::%lo0/32                     ::1                           U           lo0
ff02::%pppoe0/32                  fe80::20d:b9ff:fe2e:xc6%pppoe0 U        pppoe0
Actions #8

Updated by Wouter Snels over 7 years ago

Mar 22 13:03:30 wan php: rc.newwanipv6: rc.newwanipv6: Failed to update wan IPv6, restarting...
Mar 22 13:03:32 wan dhcp6c9087: update_ia: status code for NA-0: no addresses

Actions

Also available in: Atom PDF