Project

General

Profile

Bug #3219

Forwarded domain with underscore should be allowed to add

Added by Mathieu Simon about 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DNS Forwarder
Target version:
Start date:
09/20/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Something I completely missed with 2.1 but realized the UI doesn't allow yet, it also affect previous 2.0 releases (verified with 2.0.3)

In environments with Active Directory-integrated DNS zones the use of subdomains with leading underscores is quite common.
Every AD environent has a couple of zones like _msdcs.example.net or _sites.example.ne with some SRV required for proper AD operation.

Adding a Domain forwarding via GUI is not possible as it doesn't recognize such a domain name as valid.
While the use of underscore is not be allowed for hostnames (RFC 952), they are not forbidden should be for domain names (so it's not MS circumventing RFCs this time) ;-)

The current workaround I have is to edit config.xml manually, define the forwarded domains and restarting dnsmasq.
Afterwards the GUI doesn't seem to scream but correctly lists them in the UI, so it's more likely to require modification the input validation.

Associated revisions

Revision bc12ae8a (diff)
Added by Chris Buechler about 4 years ago

Underscores are valid characters in domains. Fixes #3219

History

#1 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Resolved
  • Target version set to 2.2
  • Affected Version changed from 2.1 to All

fixed in 2.2

Also available in: Atom PDF