Project

General

Profile

Bug #3223

pfr_unroute_kentry: delete failed and freeze

Added by xavier Lemaire almost 7 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
-
Start date:
09/22/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1
Affected Architecture:

Description

I just tested the update in pre-production for 2.1_release
The configuration is CARP and BGP with 2 machines.

Unfortunately the slave makes a crash with this error message pfr_unroute_kentry: delete failed.

Unreachable slave. I tried both ways each time the slave makes a crash after a few minutes. Whether one to the other machines.

To be safe I turned off the Synchronize States and Configuration Synchronization Settings

The solution on thoses box was stable in all version from 1.2.x to 2.0.x

do you have any idéas ?.

History

#1 Updated by xavier Lemaire almost 7 years ago

sorry Affected Architecture: i386

#2 Updated by Ermal Luçi almost 7 years ago

Do you have large tables in your setup?

#3 Updated by Chris Buechler over 6 years ago

  • Category changed from CARP to Operating System
  • Target version deleted (2.1.1)

#4 Updated by xavier Lemaire over 6 years ago

Sorry i forget this story. But yes I have very very big tables in my setup where i have this trouble.
But i had some trouble with network hardware in same time. When i solved the hardware trouble i see juste two time it in 3 month.

#5 Updated by xavier Lemaire over 6 years ago

2.1.1-RELEASE (amd64) built on Tue Apr 1 15:22:32 EDT 2014 FreeBSD 8.3-RELEASE-p14 on new hp server 360 G6
Intel(R) Xeon(R) CPU E5-2407 v2 @ 2.40GHz 4 CPUs: 1 package(s) x 4 core(s)
I see this trouble back . And yes i have some alias and i use pfblocker with some big table. And opengbp

#6 Updated by xavier Lemaire over 6 years ago

hi all,
for follow this trouble, i erase all my pfblocker's tables and i just keep two very importantes. Today it s very stable. So thank you to Ermal Luçi about this idéa. I think this trouble is in freebsd not in pfsense. I have some firewall with a lot of table but without carp are stable.

#7 Updated by Chris Buechler almost 5 years ago

  • Status changed from New to Resolved

this is fixed in 2.2.x versions.

Also available in: Atom PDF