Project

General

Profile

Bug #3466

Restarting OpenVPN Server restarts other services

Added by B. Derman over 6 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
02/19/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1
Affected Architecture:
i386

Description

Visit "Status -> OpenVPN" and press the "Restart openvpn Service" button for a running server.

When the OpenVPN server restarts and the "Status -> Services" page is presented, notice that the NTP service is stopped (and will restart, momentarily).

In addition, the NUT service is also restarted.

History

#1 Updated by Chris Buechler about 6 years ago

  • Status changed from New to Rejected

there is a separate ticket to allow package maintainers to specify whether a package restarts upon IP change. The remainder happens because when an IP changes/added/removed, certain services must be restarted in order to function correctly, that's not a bug.

Also available in: Atom PDF