Project

General

Profile

Actions

Feature #3507

closed

add regex? to dhcpv6 Static mappings to convert windows DUID to BSD formatted DUID (replace -s with :s)

Added by Andrew Stuart over 7 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/06/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:

Description

There is an unmentioned? Feature in DHCP Static maps, that adding windows formatted Mac addresses, pfSense silently reformats the string to the correct format.
To be consistent, I request this be added to DHCPv6, as currently the formatting isn't corrected from -s to :s, thus causing the following error:

php: /services_dhcpv6.php: The command '/usr/local/sbin/dhcpd -6 -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpdv6.conf -pf /var/run/dhcpdv6.pid em0' returned exit code '1', the output was 'Internet Systems Consortium DHCP Server 4.2.5-P1 Copyright 2004-2013 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/ /etc/dhcpdv6.conf line 24: expecting string or hexadecimal data. host-identifier option dhcp6.client-id 00-01-00-01-18-8C-8B-F5-8C-89-A7-18-CA-5 ^ Configuration file errors encountered -- exiting If you did not get this software from ftp.isc.org, please get the latest from ftp.isc.org and install that before requesting help. If you did get this software from ftp.isc.org and have not yet read the README, please read it before requesting help. If you intend to request help from the dhcp-server@isc.org mailing list, please read the section on the README about submitting b

Note: I do realize the page specifically says in xx:xx:... format, but so does DHCP. It would just be nice if both acted the same way.

Actions #1

Updated by Chris Buechler over 5 years ago

  • Status changed from New to Duplicate

duplicate of #2568

Actions

Also available in: Atom PDF