Project

General

Profile

Bug #3540

100% CPU-Issue when IPv6 DHCP with stateless addresses is active

Added by Ph. T over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
03/21/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1-IPv6
Affected Architecture:
amd64

Description

The process check_reload_status takes 100% CPU-Load
if the following conditions are given:

Pfsense Relase:
2.1-RELEASE (amd64)
built on Wed Sep 11 18:17:48 EDT 201

WAN is set to
IPv6 Configuration Type [DHCP]

and a
IPv6 DHCP-Server is active which is giving only stateless adresses.

With a high frequency pfsense is requesting dhcp.

We suspect that DHCPv6 is not handled properly;
e.g. replys are only accepted if the statfull-flag is set. The System seems
to reasks the statless dhcp Server with a high frequency forever, therefore
producing high cpu load (100%).

Workaround:
- Disable DHCPv6 or set a static address

Probably related issues:
https://forum.pfsense.org/index.php?topic=51468.0
+ https://redmine.pfsense.org/issues/2555
(the issue is closed, but without finding a reason for the high cpu-load)

If you need additonal Information contact me.

History

#1 Updated by Chris Buechler over 4 years ago

  • Subject changed from 100% CPU-Issue when IPv6 DHCP is active to 100% CPU-Issue when IPv6 DHCP with stateless addresses is active
  • Category set to Interfaces
  • Target version set to 2.2

#2 Updated by Ermal Luçi over 4 years ago

This needs to be confirmed again when the 2.2 snapshots are active.

#3 Updated by Ermal Luçi over 4 years ago

  • Status changed from New to Feedback

#4 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

haven't seen this in 2.2

Also available in: Atom PDF