Project

General

Profile

Actions

Bug #365

closed

CARP status page display broken when skipping VHIDs

Added by Chris Buechler almost 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
CARP
Target version:
Start date:
02/18/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

When CARP VIPs are configured that skip VHIDs, status_carp.php's display is broken. Example on 2.0 attached, with one VHID 1 and one on 8.

This is also an issue in RELENG_1_2, but doesn't need fixed there.


Files

carp-status-1.png (4.2 KB) carp-status-1.png Chris Buechler, 02/18/2010 11:49 PM
carp-status-2.png (7.15 KB) carp-status-2.png Chris Buechler, 02/18/2010 11:51 PM
vip_list_with_vhid_skipped.jpg (18.4 KB) vip_list_with_vhid_skipped.jpg CARP VIP List, with VHID skipped Pierre POMES, 02/19/2010 08:29 PM
carp_ok_with_vhid_skipped.jpg (12.1 KB) carp_ok_with_vhid_skipped.jpg CARP Screen OK Pierre POMES, 02/19/2010 08:29 PM
Actions #1

Updated by Chris Buechler almost 12 years ago

Another example (from 1.2.3, though the source appears largely the same) here. Note the IPs do display properly, edited out here for privacy reasons. The first two are VHID 1 and 2, the next (first broken one) is VHID 9 and they increment sequentially from there.

Actions #2

Updated by Pierre POMES almost 12 years ago

Hi Chris,

I tried to reproduce it, without success. I tried to define (on my LAN) two CARP VIP with VHID 2 and 5, and the carp screen is ok. Please note that I don't have CARP backup on my LAN.

Screenshots attached.

Actions #3

Updated by Chris Buechler almost 12 years ago

  • Status changed from New to Closed

it was an older 2.0 that showed this for me, latest is good in all scenarios that I've seen that aren't right in 1.2.x and earlier 2.0 snapshots.

Actions

Also available in: Atom PDF