Project

General

Profile

Bug #3678

Kernel panic: "Bogus interrupt trigger mode" on Intel J1900

Added by Ken Masterson over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/24/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1.2
Affected Architecture:
amd64

Description

Asrock Q1900M motherboard with Bay Trail Intel J1900 is unable to boot pfSense 2.1.3 live CD and USB images. A kernel panic is reported, with message "Bogus interrupt trigger mode".

pfSense 2.2-DEVELOPMENT snapshot 20140523-0808 is also affected.

FreeNAS bug #4996 appears to be the same problem, and links to freeBSD ticket 187966, which includes a patch.

History

#1 Updated by Dan E over 4 years ago

I can confirm this issue on a Gigabyte GA-J1900N-D3V. I've tried AMD64/i386 builds of 2.1.3 as well as 2.2-DEVELOPMENT-4g-amd64-nanobsd-vga-20140526-1016. No BIOS options have any impact.. just can't get it to boot :-(

Ken Masterson wrote:

Asrock Q1900M motherboard with Bay Trail Intel J1900 is unable to boot pfSense 2.1.3 live CD and USB images. A kernel panic is reported, with message "Bogus interrupt trigger mode".

pfSense 2.2-DEVELOPMENT snapshot 20140523-0808 is also affected.

FreeNAS bug #4996 appears to be the same problem, and links to freeBSD ticket 187966, which includes a patch.

#2 Updated by Eric Tol over 4 years ago

Dan E wrote:

I can confirm this issue on a Gigabyte GA-J1900N-D3V. I've tried AMD64/i386 builds of 2.1.3 as well as 2.2-DEVELOPMENT-4g-amd64-nanobsd-vga-20140526-1016. No BIOS options have any impact.. just can't get it to boot :-(

Ken Masterson wrote:

Asrock Q1900M motherboard with Bay Trail Intel J1900 is unable to boot pfSense 2.1.3 live CD and USB images. A kernel panic is reported, with message "Bogus interrupt trigger mode".

pfSense 2.2-DEVELOPMENT snapshot 20140523-0808 is also affected.

FreeNAS bug #4996 appears to be the same problem, and links to freeBSD ticket 187966, which includes a patch.

I can confirm on Gigabyte GA-J1900N-D3V as well.

#3 Updated by Joel Larsson over 4 years ago

I can confirm the same issue with ASUS J1900I-C. Both with pfsense 2.1.3 and with pfSense-memstick-serial-2.2-DEVELOPMENT-amd64-20140613-1600.img.

#4 Updated by Steve Wheeler over 4 years ago

So this looks like a BIOS bug (bad ACPI table) that would be possible to workaround.
Those of you with the Gigabyte GA-J1900N-D3V have you updated to the most recent BIOS (F3)? There are other running that board successfully:
https://forum.pfsense.org/index.php?topic=73518.msg418094#msg418094

Steve

#5 Updated by Aaron Fields over 4 years ago

I'm having no luck getting pfsense to boot on my Intel NUC DN2820. Kernel panics with "Bogus interrupt trigger mode.".

#6 Updated by Stuart Lamble over 4 years ago

Same problem here on the Gigabyte J1900N-D3V motherboard.
Also put some info up on this link on the forum:
https://forum.pfsense.org/index.php?topic=72305.15

#7 Updated by Ken Masterson over 4 years ago

Someone pointed out that this appears to be a BIOS ACPI table problem. I suggest that we start asking manufacturers if they can update their BIOS to resolve the issue.

#8 Updated by Stuart Lamble over 4 years ago

I have logged a call with Gigabyte siting the BIOS ACPI issues and that F3 bios update does not address this problem.
Lets see how good Gigabyte is in addressing this issue.
Will post any updates back here as and when I get them.

#9 Updated by Stuart Lamble over 4 years ago

Still no reply from Gigabyte...

#10 Updated by Chris Buechler over 4 years ago

I doubt you'll get a reply in any reasonable amount of time from motherboard manufacturers, but maybe if enough people make noise it'll get fixed in a future BIOS update.

This has been worked around in FreeBSD, though apparently not MFCed to 10-STABLE, so not in 2.2 at this time.

#11 Updated by Stuart Lamble over 4 years ago

A response.... and the last gigabyte anything I ever buy!

"

Thank you for your kindly mail and inquiry. According to the specification on our product page, this motherboard only supports Windows 8.1/8 32-bit/64-bit and Windows 7 64-bit. Due to different Linux support condition provided by chipset vendors, please download Linux driver from chipset vendors' website or 3rd party website. If you have any problem with Linux, we suggest you to use the operation system the product can support. Thank you for your cooperation.

Regards,
GIGABYTE

"

#12 Updated by Stuart Lamble over 4 years ago

Just for info, no change with release 2.1.4
As said above, the workaround did not make it into this release.

#13 Updated by Eric Tol over 4 years ago

How do we get it in the next update?

#14 Updated by Stuart Lamble over 4 years ago

I am not entirely sure...

Chris Buechler seemed to know a little about this, as stated above "This has been worked around in FreeBSD, though apparently not MFCed to 10-STABLE, so not in 2.2 at this time."

Chris, how do we make this happen?

#15 Updated by Chris Buechler over 4 years ago

  • Status changed from New to Resolved
  • Target version set to 2.2

this was since fixed in 9 and 10 stable FreeBSD, current 2.2 should work here

#16 Updated by Ken Masterson over 4 years ago

Chris Buechler wrote:

this was since fixed in 9 and 10 stable FreeBSD, current 2.2 should work here

I can confirm that the issue appears to be fixed in the most recents builds of pfSense 2.2.x

Also available in: Atom PDF