Project

General

Profile

Bug #373

Package Manager not available in menus

Added by Andrew Vliet over 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
Start date:
02/22/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Package Manager option is not available through the menu system - can only be accessed by adding the "Installed Packages" item in the dashboard and then clicking on the "Installed Packages" title. Once accessed, Package manager can not contact pfsense.com to download a package list.

History

#1 Updated by Chris Buechler over 9 years ago

  • Status changed from New to Feedback
  • Target version set to 2.0

The menu is there under System > Packages on every install I have, and never heard of it not appearing. The only way that menu item doesn't appear is if platform is not "pfSense" or "nanobsd", and those are the only two platforms on 2.0 unless you're running off the live CD.

Going to need more info.

#2 Updated by Andrew Vliet over 9 years ago

Chris Buechler wrote:

The menu is there under System > Packages on every install I have, and never heard of it not appearing. The only way that menu item doesn't appear is if platform is not "pfSense" or "nanobsd", and those are the only two platforms on 2.0 unless you're running off the live CD.

Going to need more info.

System --> Packages does not exist here. Not sure what you mean by "pfsense" as a platform - I used pfSense-2.0-BETA1-20100221-0542.iso to install this system on vmware esxi 4.0 update 1 i386 virtual hardware.

#3 Updated by Chris Buechler over 9 years ago

Go to Diagnostics > Command, and in the PHP Execute box, paste in:

echo $g['platform'];

Then paste here what it shows in the gray box.

#4 Updated by Andrew Vliet over 9 years ago

Returns "pfsense"

#5 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to Closed

Everything is fine then apparently. No idea what you're seeing but this isn't enough info to be a legit, actionable bug report. No one else has reported it, we've never seen it, and based on the info you've provided the very simple code that puts this menu in place can't possibly have a problem. If it's still a problem with the latest snapshot, and you've tried multiple browsers on multiple machines, post to the forum or mailing list with info. If a specific cause can be found, this can be re-opened.

#6 Updated by sanjiv marathe over 8 years ago

I faced this issue too. It happens if you are running out of LiveCD. Install pfsense 2.0 to hard disk and then "Packages" appears under "System" menu.

#7 Updated by J Smith about 8 years ago

I'm running version 1.2.3-RELEASE and no option in the system menu to add packages either. If it's related to running on LiveCD, how to get packages added? I like running from Ram so no HDD noise and constant power draw. If a technical difficulty to get packages with LiveCD then please add a menu item that tells the user 'System->Packages->No packages capability if running LiveCD, need full HDD install' so they know what the problem is without googling. I ended up here after trying to get FreeSwitch Package installed and 'why no packages option in the menu?'...

#8 Updated by Jim Pingle about 8 years ago

Packages cannot be used from the LiveCD, and there is no way to support them while running from the LiveCD. Adding packages requires modifying the filesystem, which can't be done on LiveCD because it's a CD, and read only.

There may be a technical workaround but it would be a lot of work for very little gain, especially since CD and other optical media are becoming less and less common, and if you're running on USB flash media you may as well use NanoBSD/embedded versions instead.

Also available in: Atom PDF