Project

General

Profile

Bug #374

"Register DHCP leases in DNS forwarder" doesn't work

Added by Chris Buechler about 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DNS Forwarder
Target version:
Start date:
02/22/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

The DNS Forwarder option "Register DHCP leases in DNS forwarder" does not work. Hostnames are not registered for any clients.

I'm seeing the same as here:
http://forum.pfsense.org/index.php/topic,23095.0.html

rc.parse-isc-dhcpd.patch (1.38 KB) rc.parse-isc-dhcpd.patch patch to add entries to /etc/hosts properly Adam Stylinski, 02/25/2010 01:50 PM
services.inc.patch (376 Bytes) services.inc.patch fixes services.inc so the function services_parse_dhcp_hostnames() pulls in global $config and forks rc script in background Adam Stylinski, 02/25/2010 08:22 PM

Associated revisions

Revision 7b819cdb (diff)
Added by jim-p about 9 years ago

A couple fixes for DHCP lease parsing. Ticket #374

Revision 79afe4e4 (diff)
Added by Ermal Luçi about 9 years ago

Use new arguments passing style for dhcpleases. Ticket #374.

Revision 956950de (diff)
Added by Ermal Luçi almost 9 years ago

Fixes #374. Actually reload teh dhcpleases utility whenever the hosts files is regenerated to avoid problems.

History

#1 Updated by Adam Stylinski about 9 years ago

I can tell you why the leases aren't going in /etc/hosts and have a pretty simple fix (although it's so shallow I'm not even going to post a patch file). However, now that I'm getting the dynamic leases in the /etc/hosts file, I'm resolving them with nslookup on the lan, but no other network services resolve the host correctly.

Basically the file /etc/rc.parse-isc-dhcpd is parsing the dhcp.lease file, and it is greping out the word "lease". Unfortunately, this appears in several places in the comments section. After the files are catted and tailed before they go into the while loops, run it through a grep -v "#" and then pipe it through all that.

However, it still doesn't explain why my machines are correctly able to resolve my static hosts but not dynamic. Also before I the /etc/rc.par-isc-dhcpd file by hand, it didn't seem to get used.

#2 Updated by Adam Stylinski about 9 years ago

Eh, that's supposed to say before I ran /etc/rc.parse-isc-dhcpd by hand. I don't know if the php is calling it properly if at all. But running it by hand did correctly add isc's to my /etc/hosts. But still, nothing but nslookup is resolving these hostnames. I haven't rebooted any of the machines since, so is it perhaps a DNS cache issue? But then why would nslookup still work?

#3 Updated by Adam Stylinski about 9 years ago

Nevermind, the bug actually is that shallow. Here's a patch that fixes everything.

#4 Updated by Dan Andersen about 9 years ago

I've applied Adam's patch, and I can verify that running /etc/rc.parse-isc-dhcpd does cause the leases to get added to /etc/hosts. nslookup from local machines works fine, as does ping. Prior to the patch my /etc/hosts file only contained my static DHCP entries.
Unfortunately it seems that it (the running of /etc/rc.parse-isc-dhcpd) is not happening automatically, even after a reboot.

#5 Updated by Adam Stylinski about 9 years ago

Indeed I was correct in that the php was never calling it in the first place. This shell script is pretty much designed so that it can be a startup script and forked in the background, though. So I'm going to go ahead and suggest that it is placed in the init subsystem.

#6 Updated by Adam Stylinski about 9 years ago

Fixed it with another patch, the global $config wasn't being pulled in for some reason :). This patch is for /etc/inc/services.inc

#7 Updated by Adam Stylinski about 9 years ago

I may have found a new bug related to this issue. It may have something to do with the fact that tail -F is looking for an inode change, but over time my static leases seem to disappear from the /etc/hosts.

#8 Updated by Ermal Luçi about 9 years ago

  • Status changed from New to Feedback

A completely different solution is in place in new snapshots.
Please test.

#9 Updated by Adam Stylinski about 9 years ago

Doesn't work with DHCP leases at all.

#10 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to New

#11 Updated by Ermal Luçi about 9 years ago

There were problems solved lately. Please test with new snapshots.

#12 Updated by Adam Stylinski about 9 years ago

Still no difference as of BETA1-20100329-1141, DHCP leases are not in there. I'm resulting to running that script that I fixed by hand and forking it in the background :-/.

#13 Updated by Ermal Luçi about 9 years ago

Can you provide a little debugging here.
ps -ax |grep dhcp
content of dhcpd.leases
contents of /var/etc/hosts file.

#14 Updated by Adam Stylinski about 9 years ago

  1. ps -ax | grep dhcp
    13215 ?? Ss 0:00.01 /usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /var/dhcpd/etc/dhcpd.conf em0 fxp0
    40171 ?? S 0:00.03 /usr/local/sbin/dnsmasq --local-ttl 1 --all-servers --dns-forward-max=5000 --cache-size=10000 --dhcp-hostsfile=/var/etc/hosts
    61384 0 S+ 0:00.01 grep dhcp

lease 192.168.1.25 {
starts 4 2010/03/04 23:16:11;
ends 5 2010/03/05 01:16:11;
tstp 5 2010/03/05 01:16:11;
binding state free;
hardware ethernet 00:26:ff:96:f4:e1;
uid "\001\000&\377\226\364\341";
}
lease 192.168.1.20 {
starts 4 2010/03/11 12:11:04;
ends 4 2010/03/11 14:11:04;
tstp 4 2010/03/11 14:11:04;
binding state free;
hardware ethernet 00:19:d2:44:f0:e1;
uid "\001\000\031\322D\360\341";
}
lease 192.168.1.21 {
starts 0 2010/03/21 03:48:40;
ends 0 2010/03/21 05:48:40;
tstp 0 2010/03/21 05:48:40;
binding state free;
hardware ethernet 00:22:5f:c8:f6:20;
uid "\001\000\"_\310\366 ";
}
lease 192.168.1.19 {
starts 1 2010/03/29 10:26:14;
ends 1 2010/03/29 12:26:14;
tstp 1 2010/03/29 12:26:14;
binding state free;
hardware ethernet 00:1f:3c:c1:bf:28;
uid "\001\000\037<\301\277(";
}
lease 192.168.1.23 {
starts 1 2010/03/29 21:11:05;
ends 1 2010/03/29 23:11:05;
tstp 1 2010/03/29 23:11:05;
binding state active;
next binding state free;
hardware ethernet 00:01:02:c9:3a:76;
uid "\001\000\001\002\311:v";
client-hostname "wap1";
}
lease 192.168.1.22 {
starts 1 2010/03/29 21:23:02;
ends 1 2010/03/29 23:23:02;
tstp 1 2010/03/29 23:23:02;
binding state active;
next binding state free;
hardware ethernet 00:50:da:b9:7e:b6;
uid "\001\000P\332\271~\266";
client-hostname "wap2";
}
lease 192.168.0.244 {
starts 0 2010/02/14 20:17:42;
ends 0 2010/02/14 20:57:07;
tstp 0 2010/02/14 20:57:07;
binding state free;
hardware ethernet 00:1b:21:19:ec:63;
uid "\001\000\033!\031\354c";
}
lease 192.168.0.41 {
starts 6 2010/02/20 04:50:56;
ends 6 2010/02/20 04:56:11;
tstp 6 2010/02/20 04:56:11;
binding state free;
hardware ethernet 00:0c:29:87:40:fc;
}
lease 192.168.0.243 {
starts 3 2010/02/24 20:22:02;
ends 3 2010/02/24 21:11:15;
tstp 3 2010/02/24 21:11:15;
binding state free;
hardware ethernet 00:1b:21:19:ec:63;
}
lease 192.168.0.240 {
starts 3 2010/02/24 21:25:07;
ends 3 2010/02/24 23:25:07;
tstp 3 2010/02/24 23:25:07;
binding state free;
hardware ethernet 08:00:27:54:7e:f8;
}
lease 192.168.0.242 {
starts 1 2010/03/08 04:21:36;
ends 1 2010/03/08 06:21:36;
tstp 1 2010/03/08 06:21:36;
binding state free;
hardware ethernet 00:24:21:61:b3:3d;
uid "\001\000$!a\263=";
}
lease 192.168.0.238 {
starts 0 2010/03/14 19:42:05;
ends 0 2010/03/14 21:42:05;
tstp 0 2010/03/14 21:42:05;
binding state free;
hardware ethernet 08:00:27:ec:4f:9e;
}
lease 192.168.0.75 {
starts 3 2010/03/17 16:10:27;
ends 3 2010/03/17 18:10:27;
tstp 3 2010/03/17 18:10:27;
binding state free;
hardware ethernet 00:0c:29:79:87:5b;
uid "\001\000\014)y\207[";
}
lease 192.168.0.237 {
starts 4 2010/03/18 03:07:06;
ends 4 2010/03/18 03:09:06;
tstp 4 2010/03/18 03:09:06;
binding state free;
hardware ethernet e1:6c:d6:ae:52:90;
uid "\001\341l\326\256R\220";
}
lease 192.168.0.236 {
starts 4 2010/03/18 03:07:07;
ends 4 2010/03/18 03:09:07;
tstp 4 2010/03/18 03:09:07;
binding state free;
hardware ethernet e9:eb:b3:a6:db:3c;
uid "\001\351\353\263\246\333<";
}
lease 192.168.0.235 {
starts 1 2010/03/22 03:38:58;
ends 1 2010/03/22 05:38:58;
tstp 1 2010/03/22 05:38:58;
binding state free;
hardware ethernet 00:0c:29:55:52:0e;
}
lease 192.168.0.234 {
starts 1 2010/03/22 03:40:23;
ends 1 2010/03/22 05:40:23;
tstp 1 2010/03/22 05:40:23;
binding state free;
hardware ethernet 08:00:27:81:b6:d8;
}
lease 192.168.0.241 {
starts 2 2010/03/23 17:24:59;
ends 3 2010/03/24 03:09:10;
tstp 3 2010/03/24 03:09:10;
binding state free;
hardware ethernet 08:00:27:0c:9e:0d;
}
lease 192.168.0.239 {
starts 1 2010/03/29 20:58:39;
ends 1 2010/03/29 22:58:39;
tstp 1 2010/03/29 22:58:39;
binding state active;
next binding state free;
hardware ethernet 00:1b:21:19:ec:63;
client-hostname "mythbox3";
}

And finally:

  1. cat /var/etc/hosts
    127.0.0.1 localhost localhost.adamsnet
    69.61.211.62 pfsense.adamsnet pfsense
    192.168.0.1 pfsense.adamsnet pfsense
    192.168.1.1 pfsense.adamsnet pfsense
    129.137.4.127 pohl.adamsnet pohl
    192.168.0.245 macbox.adamsnet macbox
    192.168.0.2 downstairs.adamsnet downstairs
    192.168.0.60 nasbox.adamsnet nasbox
    192.168.0.96 G4box.adamsnet G4box
    192.168.0.116 brynns.adamsnet brynns
    192.168.0.119 freebsdbox.adamsnet freebsdbox
    192.168.0.121 mythtvbox.adamsnet mythtvbox
    192.168.0.124 BRN001BA9151890.adamsnet BRN001BA9151890

As you can see only the static leases are in there, which are always put in /etc/hosts anyway.

#15 Updated by Ermal Luçi about 9 years ago

Do you have any log entry in system logs about dhcpleases?
It should be running so the leases work.
Either you are on an old snapshot which had a problem with dhcpd.lease not present or you have tweaked your system.

#16 Updated by Adam Stylinski about 9 years ago

It is the latest snapshot and it is untampered with. Which system log, "System"?

#17 Updated by xternal x about 9 years ago

I just tried the lastest revision and it still seems to be an issue. Static is being added to hosts file, however if you try and ping/nslookup any host (Static/DHCP) it is unable to be resolved.

#18 Updated by Marcus Brown about 9 years ago

Hi,

my pfSense box hostname is "pfsense" and domain is "local"

[]/root(29): cat /etc/resolv.conf
domain local
nameserver 2X.46.237.X37
nameserver 2X.70.228.X20

[]/root(31): cat /var/etc/hosts
127.0.0.1 localhost localhost.local
192.168.9.1 pfsense.local pfsense
10.94.243.169 pfsense.local pfsense

Also, this may be the problem. My processes on pfSense box.

nobody 26384 0.0 1.0 5540 2392 ?? I 8:25AM 0:02.94 /usr/local/sbin/dnsmasq --local-ttl 1 --all-servers --dns-forward-max=5000 --cache-size=10000 --dhcp-hostsfile=/var/etc/hosts
dhcpd 46822 0.0 0.9 3304 2104 ?? Is 8:25AM 0:00.05 /usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /var/dhcpd/etc/dhcpd.conf bridge0

Note: --dhcp-hostsfile=/var/etc/hosts

. . . from the dnsmasq man page: http://www.thekelleys.org.uk/dnsmasq/docs/dnsmasq-man.html

--dhcp-hostsfile=<file>
Read DHCP host information from the specified file. The file contains information about one host per line. The format of a line is the same as text to the right of '=' in --dhcp-host. The advantage of storing DHCP host information in this file is that it can be changed without re-starting dnsmasq: the file will be re-read when dnsmasq receives SIGHUP.

-G, --dhcp-host=[<hwaddr>][,id:<client_id>|*][,net:<netid>][,<ipaddr>][,<hostname>][,<lease_time>][,ignore]

so the "--dhcp-hostsfile=/var/etc/hosts" option won't give desired results.

Ermal, are you running mdns on your network hosts? This can make local DNS resolution to appear to be working when it's really not. This happened to me and then I started to use dig to test dns lookups.

#19 Updated by Marcus Brown about 9 years ago

[2.0-BETA1] [root@pfsense.home]/root(18): ps ax | grep dhcp
  140  ??  Is     0:00.24 /usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /var/dhcpd/etc/dhcpd.conf bridge0
 1100  ??  Is     0:00.01 /usr/local/sbin/dhcpleases -l /var/dhcpd/var/db/dhcpd.leases -d local -p /var/run/dnsmasq.pid -h /var/etc/hosts
60598  ??  S      0:08.73 /usr/local/sbin/dnsmasq --local-ttl 1 --all-servers --dns-forward-max=5000 --cache-size=10000 --dhcp-hostsfile=/var/etc/hosts

[2.0-BETA1] [root@pfsense.home]/root(19): cat /var/etc/hosts
127.0.0.1    localhost localhost.home
183.89.218.112    pfsense.home pfsense
192.168.5.1    pfsense.home pfsense

[2.0-BETA1] [root@pfsense.home]/root(20): cat /var/dhcpd/var/db/dhcpd.leases
# All times in this file are in UTC (GMT), not your local timezone.   This is
# not a bug, so please don't ask about it.   There is no portable way to
# store leases in the local timezone, so please don't request this as a
# feature.   If this is inconvenient or confusing to you, we sincerely
# apologize.   Seriously, though - don't ask.
# The format of this file is documented in the dhcpd.leases(5) manual page.
# This lease file was written by isc-dhcp-V3.0.7

lease 192.168.5.242 {
  starts 2 2010/04/06 14:11:55;
  ends 2 2010/04/06 16:11:55;
  tstp 2 2010/04/06 16:11:55;
  binding state free;
  hardware ethernet 00:1c:42:69:e5:2f;
  uid "\001\000\034Bi\345/";
}
lease 192.168.5.243 {
  starts 3 2010/04/07 03:37:36;
  ends 4 2010/04/08 03:37:36;
  tstp 4 2010/04/08 03:37:36;
  binding state free;
  hardware ethernet 00:1f:f3:05:14:f9;
  uid "ae2";
}
lease 192.168.5.244 {
  starts 5 2010/04/09 02:34:54;
  ends 5 2010/04/09 04:34:54;
  binding state active;
  next binding state free;
  hardware ethernet 00:1b:63:f0:7e:96;
  uid "\001\000\033c\360~\226";
  client-hostname "AppleTV";
}
lease 192.168.5.245 {
  starts 5 2010/04/09 03:00:12;
  ends 5 2010/04/09 05:00:12;
  binding state active;
  next binding state free;
  hardware ethernet 00:21:91:56:4d:21;
  uid "\001\000!\221VM!";
  client-hostname "DNAS";
}

#20 Updated by Adam Stylinski almost 9 years ago

Any updates to this problem yet? Do we know why Ermal's solution is not working as expected?

#21 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

Try latest snasphots it has a fix.

#22 Updated by Ermal Luçi almost 9 years ago

  • % Done changed from 0 to 100

#23 Updated by Adam Stylinski almost 9 years ago

Yay, It works.
Thanks Ermal.

#24 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

#25 Updated by Adam Stylinski almost 9 years ago

After having left pfsense running for a while my dynamic hostname resolution seems to have vanished.

uptime
11:58PM up 27 days, 10:54, 2 users, load averages: 0.08, 0.02, 0.01
The following are all static hosts:

cat /etc/hosts
127.0.0.1 localhost localhost.adamsnet
192.168.0.1 pfsense.adamsnet pfsense
129.137.4.127 pohl.adamsnet pohl
192.168.0.245 macbox.adamsnet macbox
192.168.0.2 downstairs.adamsnet downstairs
192.168.0.60 nasbox.adamsnet nasbox
192.168.0.96 G4box.adamsnet G4box
192.168.0.116 brynns.adamsnet brynns
192.168.0.119 freebsdbox.adamsnet freebsdbox
192.168.0.121 mythtvbox.adamsnet mythtvbox
192.168.0.124 BRN001BA9151890.adamsnet BRN001BA9151890
As you can see there are plenty of dynamic hosts:

cat /var/dhcpd/var/db/dhcpd.leases
All times in this file are in UTC (GMT), not your local timezone. This is
not a bug, so please don't ask about it. There is no portable way to
store leases in the local timezone, so please don't request this as a
feature. If this is inconvenient or confusing to you, we sincerely
apologize. Seriously, though - don't ask.
The format of this file is documented in the dhcpd.leases(5) manual page.
This lease file was written by isc-dhcp-V3.0.7
lease 192.168.1.25 {
starts 6 2010/06/26 22:07:28;
ends 0 2010/06/27 00:07:28;
tstp 0 2010/06/27 00:07:28;
binding state free;
hardware ethernet c4:17:fe:a4:3e:92;
uid "\001\304\027\376\244>\222";
}
lease 192.168.1.21 {
starts 0 2010/07/04 01:07:53;
ends 0 2010/07/04 03:07:53;
tstp 0 2010/07/04 03:07:53;
binding state free;
hardware ethernet 00:22:5f:c8:f6:20;
uid "\001\000\"_\310\366 ";
}
lease 192.168.1.23 {
starts 0 2010/07/04 02:11:56;
ends 0 2010/07/04 04:11:56;
binding state active;
next binding state free;
hardware ethernet 00:01:02:c9:3a:76;
uid "\001\000\001\002\311:v";
client-hostname "wap1";
}
lease 192.168.1.19 {
starts 0 2010/07/04 02:14:33;
ends 0 2010/07/04 04:14:33;
binding state active;
next binding state free;
hardware ethernet 00:1f:3c:c1:bf:28;
uid "\001\000\037<\301\277(";
client-hostname "zephyr";
}
lease 192.168.1.22 {
starts 0 2010/07/04 03:07:54;
ends 0 2010/07/04 05:07:54;
binding state active;
next binding state free;
hardware ethernet 00:50:da:b9:7e:b6;
uid "\001\000P\332\271~\266";
client-hostname "wap2";
}
lease 192.168.0.244 {
starts 0 2010/02/14 20:17:42;
ends 0 2010/02/14 20:57:07;
tstp 0 2010/02/14 20:57:07;
binding state free;
hardware ethernet 00:1b:21:19:ec:63;
uid "\001\000\033!\031\354c";
}
lease 192.168.0.41 {
starts 6 2010/02/20 04:50:56;
ends 6 2010/02/20 04:56:11;
tstp 6 2010/02/20 04:56:11;
binding state free;
hardware ethernet 00:0c:29:87:40:fc;
}
lease 192.168.0.243 {
starts 3 2010/02/24 20:22:02;
ends 3 2010/02/24 21:11:15;
tstp 3 2010/02/24 21:11:15;
binding state free;
hardware ethernet 00:1b:21:19:ec:63;
}
lease 192.168.0.240 {
starts 3 2010/02/24 21:25:07;
ends 3 2010/02/24 23:25:07;
tstp 3 2010/02/24 23:25:07;
binding state free;
hardware ethernet 08:00:27:54:7e:f8;
}
lease 192.168.0.238 {
starts 0 2010/03/14 19:42:05;
ends 0 2010/03/14 21:42:05;
tstp 0 2010/03/14 21:42:05;
binding state free;
hardware ethernet 08:00:27:ec:4f:9e;
}
lease 192.168.0.75 {
starts 3 2010/03/17 16:10:27;
ends 3 2010/03/17 18:10:27;
tstp 3 2010/03/17 18:10:27;
binding state free;
hardware ethernet 00:0c:29:79:87:5b;
uid "\001\000\014)y\207[";
}
lease 192.168.0.235 {
starts 1 2010/03/22 03:38:58;
ends 1 2010/03/22 05:38:58;
tstp 1 2010/03/22 05:38:58;
binding state free;
hardware ethernet 00:0c:29:55:52:0e;
}
lease 192.168.0.234 {
starts 1 2010/03/22 03:40:23;
ends 1 2010/03/22 05:40:23;
tstp 1 2010/03/22 05:40:23;
binding state free;
hardware ethernet 08:00:27:81:b6:d8;
}
lease 192.168.0.242 {
starts 5 2010/04/30 04:33:41;
ends 5 2010/04/30 06:33:41;
tstp 5 2010/04/30 06:33:41;
binding state free;
hardware ethernet 00:24:21:61:b3:3d;
uid "\001\000$!a\263=";
}
lease 192.168.0.241 {
starts 5 2010/05/28 21:27:45;
ends 6 2010/05/29 21:27:45;
tstp 6 2010/05/29 21:27:45;
binding state free;
hardware ethernet 08:00:27:0c:9e:0d;
}
lease 192.168.0.233 {
starts 5 2010/06/04 22:03:02;
ends 6 2010/06/05 00:03:02;
tstp 6 2010/06/05 00:03:02;
binding state free;
hardware ethernet 00:0c:29:c9:68:26;
uid "\001\000\014)\311h&";
}
lease 192.168.0.230 {
starts 2 2010/06/15 22:17:47;
ends 3 2010/06/16 00:17:47;
tstp 3 2010/06/16 00:17:47;
binding state free;
hardware ethernet 00:24:1d:20:64:12;
}
lease 192.168.0.237 {
starts 1 2010/06/21 21:51:50;
ends 1 2010/06/21 21:53:50;
tstp 1 2010/06/21 21:53:50;
binding state free;
hardware ethernet e1:6c:d6:ae:52:90;
uid "\001\341l\326\256R\220";
}
lease 192.168.0.236 {
starts 1 2010/06/21 21:51:51;
ends 1 2010/06/21 21:53:51;
tstp 1 2010/06/21 21:53:51;
binding state free;
hardware ethernet e9:eb:b3:a6:db:3c;
uid "\001\351\353\263\246\333<";
}
lease 192.168.0.15 {
starts 4 2010/06/24 01:22:30;
ends 4 2010/06/24 03:22:30;
tstp 4 2010/06/24 03:22:30;
binding state free;
hardware ethernet 00:0c:29:ad:ad:eb;
}
lease 192.168.0.231 {
starts 5 2010/06/25 21:53:01;
ends 5 2010/06/25 23:53:01;
tstp 5 2010/06/25 23:53:01;
binding state free;
hardware ethernet 00:24:1d:20:64:12;
uid "\001\000$\035 d\022";
}
lease 192.168.0.232 {
starts 6 2010/07/03 20:45:41;
ends 6 2010/07/03 22:45:41;
tstp 6 2010/07/03 22:45:41;
binding state free;
hardware ethernet 00:1f:d0:81:7e:37;
uid "\001\000\037\320\201~7";
}
lease 192.168.0.93 {
starts 0 2010/07/04 02:32:44;
ends 0 2010/07/04 04:32:44;
binding state active;
next binding state free;
hardware ethernet 00:11:24:d6:92:d8;
client-hostname "powerbook";
}
lease 192.168.0.239 {
starts 0 2010/07/04 02:55:13;
ends 0 2010/07/04 04:55:13;
binding state active;
next binding state free;
hardware ethernet 00:1b:21:19:ec:63;
client-hostname "mythbox3";
}
lease 192.168.0.82 {
starts 0 2010/07/04 03:10:12;
ends 0 2010/07/04 05:10:12;
binding state active;
next binding state free;
hardware ethernet 00:e0:b8:38:ad:8e;
uid "\001\000\340\2708\255\216";
client-hostname "bsdtop";
}
lease 192.168.1.23 {
starts 0 2010/07/04 03:11:56;
ends 0 2010/07/04 05:11:56;
binding state active;
next binding state free;
hardware ethernet 00:01:02:c9:3a:76;
uid "\001\000\001\002\311:v";
client-hostname "wap1";
}
lease 192.168.1.19 {
starts 0 2010/07/04 03:14:33;
ends 0 2010/07/04 05:14:33;
binding state active;
next binding state free;
hardware ethernet 00:1f:3c:c1:bf:28;
uid "\001\000\037<\301\277(";
client-hostname "zephyr";
}
lease 192.168.0.93 {
starts 0 2010/07/04 03:32:44;
ends 0 2010/07/04 05:32:44;
binding state active;
next binding state free;
hardware ethernet 00:11:24:d6:92:d8;
client-hostname "powerbook";
}
lease 192.168.0.239 {
starts 0 2010/07/04 03:55:13;
ends 0 2010/07/04 05:55:13;
binding state active;
next binding state free;
hardware ethernet 00:1b:21:19:ec:63;
client-hostname "mythbox3";
}

Here is the process still being displayed in ps:
root 4356 0.0 0.1 3316 1060 ?? Is 6Jun10 0:00.02 /usr/local/sbin/dhcpleases -l /var/dhcpd/var/db/dhcpd.leases -d adamsnet -p /var/run/dnsmasq.p

Sadly I think we may need to reopen this problem for feedback :(.

#26 Updated by Chris Buechler almost 9 years ago

  • Status changed from Resolved to Feedback

#27 Updated by Maximilian Riedel almost 9 years ago

Adam Stylinski wrote:

After having left pfsense running for a while my dynamic hostname resolution seems to have vanished.

Hi, the same happens to me. I can still resolve static mappings but no hostnames from dynamic leases.
Snapshot: 9th July (full)

#28 Updated by Ermal Luçi almost 9 years ago

Please try a new snapshot.
A change was made on the utility to monitor if the file is being deleted/renamed actions that will break the monitoring for leases.

#29 Updated by Adam Stylinski over 8 years ago

Well I finally got around to updating to a new snapshot a couple of days ago and it seems to still be resolving even days later. I'm a believer it's fixed for now.

#30 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF