Project

General

Profile

Bug #3771

Webinterface and dhcpdcrashes with 500+ static leases

Added by Niels Gassen over 5 years ago. Updated 3 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
DHCP Server
Target version:
-
Start date:
07/24/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1.x
Affected Architecture:
amd64

Description

I'm using pfSense 2.1.3 in a HA setup with CARP, pfsync, and dhcp failover.

I've got about 500+ static leases in my DHCP server, everytime i add or delete a lease, it takes up to 10 minutes to apply these changes or i get a time out.

Meanwhile the dhcp server isnt running, thus my clients dont get any leases.

History

#1 Updated by Renato Botelho over 5 years ago

  • Status changed from New to Rejected

I have test environments with 1000+ static mappings working perfectly on 2.1.4 and on 2.2-snapshots. You can discuss your issue on forums and mailing lists to figure out the root cause and reopen the ticket in the case it's necessary and there is a way to reproduce it.

#2 Updated by Renato Botelho over 5 years ago

  • Status changed from Rejected to Feedback

I was not supposed to close it yet, will wait more details from submitter about how to reproduce

#3 Updated by Niels Gassen about 5 years ago

It's easy to reproduce, setup an HA setup with dhcpd failover and create about 500 leases.

If I deactivate the dhcpd failover, everything works fine.

#4 Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to New

Needs re-tested on a current release or development snapshots (preferably 2.5.0 snapshots)

#5 Updated by Jim Pingle 3 months ago

  • Category changed from Web Interface to DHCP Server

Also available in: Atom PDF