Project

General

Profile

Bug #3802

DNS forwarder/resolver - IPv6 link local selections shouldn't use hard-coded addresses

Added by Eduard Rozenberg over 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DNS Resolver
Target version:
Start date:
08/11/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

Hello,

2.1.4-RELEASE (amd64)
built on Fri Jun 20 12:59:50 EDT 2014
FreeBSD 8.3-RELEASE-p16

When I select several Interfaces at https://myfirewall/services_dnsmasq.php,
if any of them are IPv6, these IPv6 selections are not synced to my second firewall.
Only the regular (non-IPv6) interfaces are synced. I'm not currently using IPv6 so
not a big deal but it looks like a bug.

DNS forwarder fw1.png (71.3 KB) DNS forwarder fw1.png Eduard Rozenberg, 08/11/2014 04:51 PM
DNS forwarder fw2.png (71 KB) DNS forwarder fw2.png Eduard Rozenberg, 08/11/2014 04:51 PM

History

#1 Updated by Chris Buechler about 4 years ago

  • Subject changed from DNS forwarder - IPv6 interface selections not synced to DNS forwarder/resolver - IPv6 link local interface selections don't match on secondary
  • Category set to DNS Resolver
  • Status changed from New to Confirmed
  • Priority changed from Normal to Very Low
  • Affected Version changed from 2.1.x to All

What it does there on the back end is stores the link local IPv6 IP of the interface, which does get synced, but doesn't exist on the secondary so it ends up being not selected. I don't think there are any typical use cases where this matters though, as the CARP or interface IP would be used in these circumstances.

This should use something generic instead of the link local IP, since changing interfaces around could break the selections. That'd also address the config sync issue noted here.

#2 Updated by Chris Buechler about 4 years ago

  • Affected Architecture changed from amd64 to All

#3 Updated by Chris Buechler about 4 years ago

  • Subject changed from DNS forwarder/resolver - IPv6 link local interface selections don't match on secondary to DNS forwarder/resolver - IPv6 link local selections shouldn't use hard-coded addresses
  • Priority changed from Very Low to Normal

also breaks config backup/restore as noted in #4641

#4 Updated by Chris Buechler almost 4 years ago

  • Status changed from Confirmed to Resolved
  • Target version set to 2.3

completed and working in 2.3 for forwarder and resolver

Also available in: Atom PDF