Project

General

Profile

Bug #3841

WebGUI 'help' menu displays beneath 'System', blocking system menu choices. regression in 2.1.5

Added by Harry Coin over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
08/29/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1.x
Affected Architecture:
All

Description

Note the attached screenshot. With the addition of the 'Gold' menu item, the 'Help' menu item is displayed beneath the System menu item on the left. The effect is it's quite difficult to move the mouse so as to actually choose System menu options, because they flip to the help menu options when rolling down over the 'help' tab toward the system options. Crossing the help tab replaces the system menu choice display with the help menu choice display.

The browser is Ubuntu Firefox v 31.

ScreenshotPFMenuBug.png (87.1 KB) ScreenshotPFMenuBug.png Screenshot showing bug Harry Coin, 08/29/2014 02:48 PM

History

#1 Updated by Jim Pingle over 5 years ago

  • Status changed from New to Rejected

Please see the other existing (closed) tickets and forum threads. It's almost always a browser cache issue but occasionally on Linux is a local font issue (Tahoma is missing) - plenty of suggestions for correction on the forum.

#2 Updated by Harry Coin over 5 years ago

Same thing happens in Google's Chromium browser as Mozilla's Firefox on Xubuntu Long Term Support v 14.04 'Trusty'. So, there's two 'off the shelf, out of the box' "vanilla" ubuntu browsers written by two entirely separate groups pfsense gui doesn't work with that will be around for at least two years. Might be worth re-assessing rejecting this. However pretty 'Tahoma' is, can it be worth it?

#3 Updated by Doktor Notor over 5 years ago

Tahoma missing is NOT a Linux issue. You must be kidding. The Tahoma font is not freely licensed in the first place. Your "open source" firewall now requires a non-free MS font to be administered from OSS systems? Please, get back to senses (not behind electric fences). Also, the CSS cached fiasco could have been avoided by properly configuring the Expires headers on the pfSense's lighttpd. I also note a total lack of testing. Well done.

#4 Updated by Jim Pingle over 5 years ago

We did test it quite a lot, but we don't have a copy of every Linux distro out there to test against. It worked fine on Ubuntu 14.04 and some others (IIRC a few copies of Mint and similar), but everyone's installs are different, some may have had add-on fonts installed, etc. We're looking into the best path for a fix. We intended to implement URL fingerprinting to force a fresh copy of the CSS to be reloaded, but there wasn't enough time to do that properly for 2.1.5.

For most, clearing the cache or simply reloading the page is enough. For the others, we're already working on figuring out the best way to resolve the problem.

#5 Updated by Andy Sayler over 5 years ago

I'm using Ubuntu 14.04 and have this issue with both Chrome and Firefox. Caches have been cleared, etc.

See https://forum.pfsense.org/index.php?topic=81165.0.

It was working fine prior to the addition of the Gold menu item.

#6 Updated by nonaya business over 5 years ago

I cleared the issue by doing a hard refresh of the page

Ctrl-F5

While this doesn't fix the initial cause of issue, it does allow me to have proper functionality of the menu again. It was also a lot faster/easier then installing the non oss Tahoma font as others have mentioned.

pfSense 2.1.5
openSuse 13.1
Firefox 31.0

#7 Updated by Andy Sayler over 5 years ago

Neither a hard refresh nor clearing the cache seems to fix the issue for me atop Ubuntu 14.04 in either Chrome or Firefox.

#8 Updated by Jim Pingle over 5 years ago

Please use the current/open ticket #3842 and not this incorrect/old ticket. Be sure to read it first, along with other existing forum threads such as https://forum.pfsense.org/index.php?topic=81049.30

Also available in: Atom PDF