Project

General

Profile

Feature #3933

Limiter burst doesn't have any effect

Added by Chris Buechler over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper
Target version:
-
Start date:
10/13/2014
Due date:
% Done:

0%

Estimated time:

Description

No matter what you put in the burst field, the limiter behaves exactly the same as if it's 0 or null. Re-tested on the most recent 2.2 snapshot as of now, and it behaves the same in every 2.1.x stable release. For example the attached traffic graph, that's 4 Mb down (out), 2 Mb up (in) limiters. First run with no burst, second run with 400000 thrown in as the burst. Doesn't matter if that's a small number or huge number, it has no effect at all.

I'd be fine with just removing the burst field for 2.2 if fixing this is really involved.

limiter-no-burst.png (15.9 KB) limiter-no-burst.png Chris Buechler, 10/13/2014 11:27 PM

Associated revisions

Revision 5274102e (diff)
Added by Chris Buechler about 4 years ago

Hide burst for limiters, since it doesn't do anything. more details in
ticket #3933

History

#1 Updated by Ermal Luçi over 4 years ago

It will take effect only when the queue if full as normal with other shaping implementations.
If your queue is not full you will not notice this at all.

#2 Updated by Chris Buechler over 4 years ago

  • Assignee changed from Ermal Luçi to Chris Buechler

after discussion with Ermal, needs testing vs. stock FreeBSD

#3 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Confirmed
  • Assignee deleted (Chris Buechler)
  • Target version changed from 2.2 to 2.3
  • Affected Documentation 0 added

dummynet burst on stock FreeBSD 10.1 does indeed work how I'd expect it to work. Ours doesn't have any impact whatsoever, with the exact same pipe config that has the expected behavior on 10.1. This has never worked, and there are too many 2.2 target issues already, so I just commented out the burst portion from the GUI bits. Can revisit later.

#4 Updated by Ahmed Kamal about 4 years ago

Hi Chris,

This issue is a blocker for me, I would really want the bursting functionality to work. I would like to help debug this issue as much as I can. I'm new to BSDs, but I'm quite experienced with Linux .. so I can hopefully get the hang of it

Can someone please guide me into how to debug this .. What commands to run, where to look .. I mean if the kernel level functionality is correct in FreeBSD 10.1, then this strikes me as just a configuration mistake (most likely) ? or a wrong command being run by the GUI ...etc

#5 Updated by Chris Buechler about 4 years ago

it's not a config or command issue, if it were that simple I would have fixed it. It's a kernel issue with dummynet in pf.

#6 Updated by Jim Thompson about 4 years ago

  • Assignee set to Ermal Luçi

#7 Updated by Web Dawg almost 4 years ago

Would a bounty help with this?

#8 Updated by Ahmed Kamal over 3 years ago

Hi folks,

Any progress on this one? Is there any alpha version that might have this working for me to test .. Thanks!

#9 Updated by Web Dawg over 3 years ago

Target version is 2.3

https://redmine.pfsense.org/versions/16

http://snapshots.pfsense.org/

Shows 2.2.3 as latest.

So, I do not think so.

#10 Updated by Jim Thompson over 3 years ago

  • Assignee changed from Ermal Luçi to Chris Buechler

#11 Updated by Chris Buechler over 3 years ago

  • Target version deleted (2.3)

#12 Updated by Web Dawg over 3 years ago

Does this mean that this is not going to be a feature anymore?

#13 Updated by Chris Buechler over 3 years ago

It never was a functional feature. We'll look at fixing it at some point, just not for 2.3.

#14 Updated by Chris Buechler over 2 years ago

  • Tracker changed from Bug to Feature
  • Status changed from Confirmed to Closed
  • Assignee deleted (Chris Buechler)

Also available in: Atom PDF