Project

General

Profile

Bug #3962

LADVD interface handling issues with lagg and bridge

Added by Marco Verleun almost 5 years ago. Updated over 2 years ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
ladvd
Target version:
-
Start date:
10/26/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

On my pfsense 2.1.5 router I've got LADVD installed.
Two physical interfaces are bridged.

As long as I only select physical interfaces LADVD status shows the connected devices.
As soon as I select the bridge0 interface as well LADVD continues to run, but doesn't report any connected devices.

History

#1 Updated by Chris Buechler almost 5 years ago

  • Project changed from pfSense to pfSense Packages
  • Affected Version deleted (2.1.5)
  • Affected Architecture deleted (amd64)

#2 Updated by Chris Buechler almost 5 years ago

I'm guessing this is a problem with ladvd itself and nothing we're doing with it, so should likely be reported upstream to the ladvd maintainers

#3 Updated by Marco Verleun almost 5 years ago

My thoughts are that it is a GUI issue. I believe that only the physical interfaces should be shown.

#4 Updated by Chris Buechler over 4 years ago

  • Subject changed from LADVD not reporting when 'invalid' interface selected to LADVD interface handling issues with lagg and bridge
  • Category set to ladvd
  • Status changed from New to Confirmed

There is a similar issue with lagg here. Our package should probably detect when you have a bridge or lagg and put its physical interface members into ladvd's config.

#5 Updated by Kill Bill over 2 years ago

As noted in the linked commit, it's not fixable in any reasonable way: https://github.com/pfsense/FreeBSD-ports/commit/5326ea279d5bbb385b3c531b995b6672c822538f

Please, close.

Also available in: Atom PDF