Project

General

Profile

Bug #3964

Web interface fails to load on first boot

Added by Chris Buechler almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Very High
Category:
Web Interface
Target version:
Start date:
10/28/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

cert.pem file is missing on first boot of clean 2.2 nano install, which leaves the web interface dead.

[2.2-BETA][root@pfSense.localdomain]/root: lighttpd -f /var/etc/lighty-webConfigurator.conf                           
2014-10-28 05:03:45: (network.c.549) SSL: couldn't read X509 certificate from '/var/etc/cert.pem' 

Reboot the system, and it works fine.

Associated revisions

Revision 143c22f7 (diff)
Added by Renato Botelho almost 4 years ago

Decode recently created cert and key. It fixes #3964. While here, fix logical condition to create a new cert if crt or key is not present

Revision 44c7d73c (diff)
Added by Renato Botelho almost 4 years ago

Decode recently created cert and key. It fixes #3964. While here, fix logical condition to create a new cert if crt or key is not present

History

#1 Updated by Renato Botelho almost 4 years ago

  • Assignee set to Renato Botelho

#2 Updated by Renato Botelho almost 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF