Project

General

Profile

Bug #3969

apinger configuration for DHCPv6 gateway is missing interface scope on source IP and target

Added by Jim Pingle about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Gateways
Target version:
Start date:
10/31/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:
All

Description

When using a DHCPv6 WAN, apinger sets the srcip to be the interface link-local address but it does not set the scope on the source IP or target, so apinger cannot reach the gateway.

Log message (IPv6 addresses masked):

Oct 31 08:25:13 pfs22 apinger: Could not bind socket on address(fe80::a00:27ff:xxxx:xxxx) for monitoring address fe80::240:48ff:xxxx:xxxx(WAN_DHCP6) with error Can't assign requested address

Broken configuration made currently (IPv6 addresses masked):

target "fe80::240:48ff:xxxx:xxxx" {
    description "WAN_DHCP6" 
    srcip "fe80::a00:27ff:xxxx:xxxx" 
    alarms override "loss","delay","down";
    rrd file "/var/db/rrd/WAN_DHCP6-quality.rrd" 
}

Working hand-edited version (IPv6 addresses masked):

target "fe80::240:48ff:xxxx:xxxx%em0" {
    description "WAN_DHCP6" 
    srcip "fe80::a00:27ff:xxxx:xxxx%em0" 
    alarms override "loss","delay","down";
    rrd file "/var/db/rrd/WAN_DHCP6-quality.rrd" 
}

Associated revisions

Revision 3f6525c1 (diff)
Added by Renato Botelho about 4 years ago

Make sure srcip has scope when it's link-local. Should fix #3969

Revision 118218cb (diff)
Added by Renato Botelho about 4 years ago

Make sure target has scope when it's a link-local. Fixes #3969

History

#1 Updated by Jim Pingle about 4 years ago

  • Subject changed from apinger monitor IP for DHCPv6 gateway is missing interface scope in source IP configuration to apinger configuration for DHCPv6 gateway is missing interface scope on source IP and target

#2 Updated by Renato Botelho about 4 years ago

  • Assignee set to Renato Botelho

#3 Updated by Renato Botelho about 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Jim Pingle about 4 years ago

  • Status changed from Feedback to Confirmed

Source IP is scoped now but it still is not showing "online" - In my testing from earlier it looks like the target needs scoped, too. (See my example above)

#5 Updated by Renato Botelho about 4 years ago

  • Status changed from Confirmed to Feedback

#6 Updated by Jim Pingle about 4 years ago

  • Status changed from Feedback to Resolved

Looks good now, gateway shows online at boot time and still shows online across several reboots. Thanks!

Also available in: Atom PDF