Project

General

Profile

Bug #4005

There were error(s) loading the rules: rules.debug:11

Added by John D over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Rules/NAT
Target version:
Start date:
11/12/2014
Due date:
% Done:

0%

Affected Version:
2.2
Affected Architecture:
amd64

Description

(this is my first bug report, I hope it is helpful)

There appears to be an error loading the rules that generates a notice:

"There were error(s) loading the rules: /tmp/rules.debug:11: syntax error - The line in question reads [11]: 10 = { bge0_vlan15}]"

It appears to impact NAT as well. Initially I was using AON. I changed it back to automatic NAT generation and still no-go. I am able to get traffic to route locally (and without rules apparently), but no traffic will traverse NAT from any of the attached VLANs (which includes the LAN interface).

Regards,
John

Associated revisions

Revision 71f45fed
Added by Chris Buechler over 3 years ago

Don't allow interface descriptions that are strictly numbers as that
generates an invalid ruleset. Ticket #4005

History

#1 Updated by Chris Buechler over 3 years ago

  • Tracker changed from Feature to Bug
  • Status changed from New to Resolved
  • Target version set to 2.2

Thanks. The issue is an all-numeric interface description isn't valid, and no input validation prevented that. I just committed a fix to prevent that configuration. Put one or more letters in your interface description and it'll work.

Also available in: Atom PDF