Project

General

Profile

Actions

Bug #4097

closed

Unable to restart Postfix

Added by Marco Verleun about 7 years ago. Updated over 6 years ago.

Status:
Not a Bug
Priority:
Low
Assignee:
-
Category:
Postfix
Target version:
-
Start date:
12/10/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.1.5
Affected Plus Version:
Affected Architecture:

Description

Postfix seems disabled but can't enabled.
When trying to restart Postfix from the GUI nothing seems to happen. The checkbox disappears.

The logfiles show the following information:
Dec 10 20:54:51 postfix/postfix-script95066: fatal: the Postfix mail system is already running
Dec 10 20:54:49 php: /status_services.php: The command '/usr/local/etc/rc.d/postfix.sh stop' returned exit code '126', the output was '/usr/local/etc/rc.d/postfix.sh: Permission denied'
Dec 10 20:54:49 php: /status_services.php: The command '/usr/local/etc/rc.d/postfix.sh stop' returned exit code '126', the output was '/usr/local/etc/rc.d/postfix.sh: Permission denied'

Inspection of the permissions shows that the execute bit it not set. This has probably something to do with the latest package update. It worked fine before.
[2.1.5-RELEASE][]/usr/local/etc/rc.d(3): ls l
total 16
lrwxr-xr-x 1 root wheel 41 Oct 20 22:41 arpwatch -> /usr/pbi/arpwatch-amd64/etc/rc.d/arpwatch
-rwxr-xr-x 1 root wheel 357 Oct 26 12:19 arpwatch.sh
lrwxr-xr-x 1 root wheel 35 Oct 20 22:39 ladvd -> /usr/pbi/ladvd-amd64/etc/rc.d/ladvd
-rwxr-xr-x 1 root wheel 292 Dec 3 08:29 ladvd.sh
lrwxr-xr-x 1 root wheel 34 Oct 20 22:47 nrpe2 -> /usr/pbi/nrpe-amd64/etc/rc.d/nrpe2
-rwxr-xr-x 1 root wheel 1067 Oct 20 22:47 nrpe2.sh
lrwxr-xr-x 1 root wheel 39 Oct 20 23:29 postfix -> /usr/pbi/postfix-amd64/etc/rc.d/postfix
-rw-r--r-
1 root wheel 486 Nov 21 21:15 postfix.sh
lrwxr-xr-x 1 root wheel 35 Oct 20 22:37 snort -> /usr/pbi/snort-amd64/etc/rc.d/snort
-rwxr-xr-x 1 root wheel 6774 Dec 9 22:28 snort.sh
[2.1.5-RELEASE][]/usr/local/etc/rc.d(4):

  1. chmod +x postfix.sh fixes the issue but introduces a new error message:
    Dec 10 21:03:49 php: /status_services.php: The command '/usr/local/etc/rc.d/postfix.sh stop' returned exit code '1', the output was '/usr/pbi/postfix-amd64/sbin/postconf: warning: /usr/pbi/postfix-amd64/etc/postfix/master.cf: unused parameter: user=postfix'

The Postfix package version is 2.10.2 pkg v.2.3.9

Actions #1

Updated by Kill Bill over 6 years ago

When it's disabled it cannot be started, since the executable bit is removed intentionally - https://github.com/pfsense/pfsense-packages/blob/master/config/postfix/postfix.inc#L797

Uninstall the package, reboot, reinstall it. Enable it. Do NOT try to start it when disabled. It won't work.

Actions #2

Updated by Chris Buechler over 6 years ago

  • Status changed from New to Not a Bug
Actions

Also available in: Atom PDF