Project

General

Profile

Actions

Bug #4160

closed

First shutdown attempt of guest fails with open-vm-tools

Added by Chris Buechler about 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
open-vm-tools
Target version:
-
Start date:
12/30/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.2
Affected Plus Version:
Affected Architecture:
All

Description

The first attempt to send a guest shutdown results in:

Call "VirtualMachine.ShutdownGuest" for object "VM name" on vCenter Server "vcenter-hostname" failed.

The second attempt works. Confirmed on both 32 and 64 bit.

Actions #1

Updated by Andreas Peetz almost 7 years ago

The root cause of this is the package script
/usr/pbi/open-vm-tools-amd64/local/share/vmware-tools/scripts/vmware/network
calling the non-existing system scripts
/etc/rc.d/netif
/etc/rc.d/dhclient

A workaround is to prevent the VMware Tools scripts from running as described here:
http://www.v-front.de/2015/01/pfsense-22-was-released-how-to-install.html

Actions #2

Updated by Greg Siemon almost 7 years ago

I note that you recently made some changes. Were these released in the _11 release of VMWare_Tools. However, after installing this seems to have the same issues as the previous package. It appears the changes are not in the _11 release. Was this intended?

See forums post here:

https://forum.pfsense.org/index.php?topic=92622.0

Actions #3

Updated by Chris Buechler almost 7 years ago

there was still some work in progress there. The _12 version is available now.

Actions #4

Updated by Chris Buechler almost 7 years ago

  • Status changed from Confirmed to Resolved

fixed

Actions

Also available in: Atom PDF