Project

General

Profile

Bug #4164

IPsec dashboard status wrong for connections with multiple P2s

Added by Chris Buechler almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
High
Category:
IPsec
Target version:
Start date:
12/30/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

"ipsec statusall" reports connections with multiple P2s as being a single connection, which breaks the active/inactive count on the dashboard widget and the up/down status on the Tunnels tab.

Associated revisions

Revision 83b0a21a (diff)
Added by Ermal Luçi almost 5 years ago

Properly rename the var Ticket #4164

Revision 60370eb9 (diff)
Added by Ermal Luçi almost 5 years ago

Properly rename the var Ticket #4164

Revision f285d039 (diff)
Added by Renato Botelho almost 5 years ago

Fix IPsec widget for multiple P2, it fixes #4164

Revision d71f9794 (diff)
Added by Renato Botelho almost 5 years ago

Fix IPsec widget for multiple P2, it fixes #4164

History

#1 Updated by Ermal Luçi almost 5 years ago

  • Status changed from Confirmed to Feedback

I do not think is anymore an issue now that the connections with multiple phase2 on IKEv1 get split on their own connection profile in ipsec.conf!

I will put this in feedback cause it works correctly here!

#2 Updated by Eskild Skaar almost 5 years ago

I'm one of the people initially have this issue:
https://forum.pfsense.org/index.php?topic=86056.msg472022#msg472022

There is one ph1 and seven ph2 present, but only one tunnel is listed as active in the widget even if all seven tunnels are active.

I have just tested "2.2-RC (i386) built on Wed Jan 07 02:45:02 CST 2015", and the problem is still present on this system. I have edited and saved the ipsec config and restarted ipsec, but the status is still the same in the widget. Only one tunnel active.

#3 Updated by Chris Buechler almost 5 years ago

  • Status changed from Feedback to Confirmed

as suspected after previous fixes, this doesn't work, it only shows the first up.

#4 Updated by Ermal Luçi almost 5 years ago

  • Status changed from Confirmed to Feedback

#5 Updated by Eskild Skaar almost 5 years ago

Tested with "2.2-RC (i386) built on Sun Jan 11 18:19:43 CST 2015", but the problem is still present.

#6 Updated by Chris Buechler almost 5 years ago

  • Status changed from Feedback to Confirmed

same status, seems fine for everything except multiple P2s.

#7 Updated by Chris Buechler almost 5 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Ermal Luçi to Chris Buechler

Renato committed something that seems to work for this, to me for further testing.

#8 Updated by Renato Botelho almost 5 years ago

  • % Done changed from 0 to 100

#10 Updated by Chris Buechler almost 5 years ago

  • Status changed from Feedback to Resolved

this looks good now

#11 Updated by Eskild Skaar almost 5 years ago

Perfect. Thanks!

Also available in: Atom PDF