Project

General

Profile

Bug #4257

tap interfaces missing from bridge after boot

Added by Dmitriy K over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Ermal Luçi
Category:
OpenVPN
Target version:
Start date:
01/21/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

Before instance restart/after reboot:

ovpnc1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=80000<LINKSTATE>
ether 00:bd:ac:6d:00:01
inet6 fe80::2bd:acff:fe6d:1%ovpnc1 prefixlen 64 scopeid 0x9
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect
status: active
Opened by PID 14515

after instance restart:

ovpnc1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=80000<LINKSTATE>
ether 00:bd:ac:6d:00:01
inet6 fe80::2bd:acff:fe6d:1%ovpnc1 prefixlen 64 scopeid 0x9
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect
status: active
Opened by PID 31233

Associated revisions

Revision 30a61a89 (diff)
Added by Ermal Luçi over 5 years ago

Fixes #4257 With the platform_booting() fixes a regression was done on openvpn tap interfaces or dynamic ones that are part of a bridge.

Allow during bootup rc.newwanip to continue up to a ceratin part to handle bridges or other complex interfaces.

Revision 145eb990 (diff)
Added by Ermal Luçi over 5 years ago

Fixes #4257 With the platform_booting() fixes a regression was done on openvpn tap interfaces or dynamic ones that are part of a bridge.

Allow during bootup rc.newwanip to continue up to a ceratin part to handle bridges or other complex interfaces.

History

#2 Updated by Chris Buechler over 5 years ago

  • Status changed from New to Feedback
  • Priority changed from Very High to Normal
  • Target version changed from 2.2 to 2.2.1

#3 Updated by Dmitriy K over 5 years ago

Huh, team is going to release 2.2 without working tap openvpn? That's interesting ...

#4 Updated by Dmitriy K over 5 years ago

To remind you: there is no traffic between sites after reboot. Both sides are UP and RUNNING and NOTHING goes between.

#5 Updated by Chris Buechler over 5 years ago

  • Subject changed from OpenVPN bridged/tap interfaces are missing PROMISC flag to tap interfaces missing from bridge after boot
  • Status changed from Feedback to Confirmed
  • Assignee set to Renato Botelho
  • Priority changed from Normal to High
  • Target version changed from 2.2.1 to 2.2

at the time I set it to 2.2.1, 2.2-release was already built and signed. Since we're rebuilding it for other reasons, moving this back to 2.2.

Updated subject to actual problem, the tap interface is missing from the bridge after boot.

Renato: check 22vpntest, bridge0 interface. You can reboot that box all you want to test.

#6 Updated by Ermal Luçi over 5 years ago

  • Status changed from Confirmed to Feedback

Fixed anything else apart taps through this issue.

#7 Updated by Ermal Luçi over 5 years ago

  • Assignee changed from Renato Botelho to Ermal Luçi

#8 Updated by Ermal Luçi over 5 years ago

  • % Done changed from 0 to 100

#9 Updated by Ermal Luçi over 5 years ago

#10 Updated by Chris Buechler over 5 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF