Project

General

Profile

Bug #4308

LAGG LACP defaults to strict mode in FreeBSD >= 10

Added by Chris Buechler over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Category:
Interfaces
Target version:
Start date:
01/27/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

In FreeBSD 10.0 and newer, LAGG with LACP defaults to strict mode. If it's not getting LACPDUs on the ports, it doesn't bring them up. That's opposite pre-10.0 behavior. This change will break a number of situations using LACP unless users disable strict mode as noted in the 2.2 upgrade guide.
https://doc.pfsense.org/index.php/Upgrade_Guide#LAGG_LACP_Behavior_Change
Many existing configurations use passive LACP, and a good deal of those on lower end switches that don't support active.

This should default to strict mode being disabled, with a checkbox on interfaces_lagg_edit.php when LACP is selected for "enable strict mode".

History

#1 Updated by Jim Thompson over 5 years ago

Can we talk about not disabling strict mode? FreeBSD 10 runs LAGG LACP in 'strict' mode for a reason.

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=185967 for reference and background.

So the issue is likely that the customer switch is not set up correctly, or they're running a poor implementation.
802.1AX-2008 says it needs receive LACPDU from partners: Switch needs to be in ACTIVE mode.

I would much rather document how to fix this than t restore the old bad default.
The previous behavior should be considered a bug and the standard should be respected

#2 Updated by Chris Buechler over 5 years ago

  • Assignee set to Chris Buechler
  • Affected Version changed from 2.1 to 2.2

After reconsideration, I agree we should keep the existing default. I'm not sure that's the right answer for upgraded configs as it seems like a POLA violation, but leaning towards leaving things as is and making sure it's as prominently noted as possible in the release notes (including future 2.2.x releases) and upgrade section. I'll review that.

#3 Updated by Ermal Lu├ži over 5 years ago

The problem i think is that on FreeBSD 10 you have no tunnable to revert to 8.x behaviour.
That is only on HEAD.

#4 Updated by Chris Buechler over 5 years ago

  • Status changed from Confirmed to Closed

It's best to leave as is, the upgrade and release notes describe how to work around pre-upgrade if necessary, and we'll make sure to continue to add that note to all 2.2.x release notes to make it as clear as possible.

Also available in: Atom PDF