Project

General

Profile

Bug #4314

Traffic Shaper Wizard not accepting an alias in the "Upstream SIP Server" text box

Added by Muchacha Grande almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
01/27/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

When using the traffic shaper wizard "Multiple LAN/WAN" I choose to prioritize voice over IP traffic and use a generic provider.
In the "Upstream SIP Server" text box I use a previosily created alias with the addresses of my SIP service providers.
When the wizard finishes, it generates the queues correctly but it wont generate the floating rules as intended.
I runned this wizard in version 2.1.5 and it generates two floating rules automatically using the SIP server alias as source on one rule and as destination on the other.
In order to let the wizard handle as much as posible of the shapers config I run the wizard again and I can see the parameters used in the previous run as expected, except for the alias configured in the "Upstream SIP Server" text box that, for some reason, is empty.
Finally I create the floating rules manually and it works fine. So I think that the problem is mainly the operation of the wizard itself.

Associated revisions

Revision 7efe99b5 (diff)
Added by Phillip Davis almost 5 years ago

Traffic Shaper Wizard Upstream SIP Server

Not being remembered and actioned.
Bug #4314

Revision b8150520 (diff)
Added by Phillip Davis almost 5 years ago

Traffic Shaper Wizard Upstream SIP Server

Not being remembered and actioned.
Bug #4314

History

#1 Updated by Phillip Davis almost 5 years ago

I think this should fix it:
https://github.com/pfsense/pfsense/pull/1453
The field name for that had been changed in the wizard ".inc" files but not in the corresponding ".xml" files.

#2 Updated by Muchacha Grande almost 5 years ago

I applied the patch and it works ok now. The wizard remembers the text box content and the floating rules are automatically created upon wizard execution.

#3 Updated by Ermal Lu├ži almost 5 years ago

  • Status changed from New to Feedback

Merged pull 1453

#4 Updated by Chris Buechler over 4 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF