Project

General

Profile

Bug #4318

gen_subnet_max returns incorrect result for 32 bit

Added by Chris Buechler over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
01/27/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:
i386

Description

gen_subnet_max returns incorrectly on 32 bit 2.2. One example, WoL will always throw in 255.255.255.255 as the broadcast address, because this:

return long2ip(ip2long($ipaddr) | (0xFFFFFFFF >> $bits));

always returns 255.255.255.255 on 32 bit. It works on 64 bit.

Associated revisions

Revision e69a0cf3 (diff)
Added by Renato Botelho over 4 years ago

Fix #4318 - gen_subnetv4_max() not working on 32bit

Revision 7094c303 (diff)
Added by Renato Botelho over 4 years ago

Fix #4318 - gen_subnetv4_max() not working on 32bit

History

#1 Updated by Renato Botelho over 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#3 Updated by Chris Buechler over 4 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF