Project

General

Profile

Actions

Bug #437

closed

Y2K38 bug in user manager expiration

Added by Chris Buechler over 11 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
User Manager / Privileges
Target version:
Start date:
03/19/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

If you put an expiration date past 20380119, such as 02/01/2038, validation fails with:

"Invalid expiration date format; use MM/DD/YYYY instead."

Maybe the date picker shouldn't go that far, or change the input validation to show an appropriate message. Not sure we need to fix the fact that you can't set expirations 28 years in the future right now.

Actions #1

Updated by Scott Ullrich about 11 years ago

  • Target version changed from 2.0 to 2.1

Lets address in 2.1.

Actions #2

Updated by Yehuda Katz almost 10 years ago

The issue is the call to strtotime which is limited to 2038 in 32-bit versions of PHP. The only solution that will work in 32-bit and 64-bit versions is to switch to the DateTime class. I am looking at that now.

Actions #4

Updated by Yehuda Katz almost 10 years ago

I see that Seth merged my pull request: e32805d9

Actions #5

Updated by Yehuda Katz almost 10 years ago

that should have said e32805d9

Actions #6

Updated by Ermal Luçi almost 10 years ago

  • Status changed from New to Feedback
Actions #7

Updated by Chris Buechler over 9 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF