Project

General

Profile

Bug #4389

gif0 tunnel for ipv6 using a carp-ip to the outside world stops working upon reboots and some config changes

Added by Pi Ba over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
02/07/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

gif0 tunnel for ipv6 using a carp-ip to the outside world stops working upon reboots and some config changes

I found that the whole gif0 interface nolonger exists, saving the OPT1 config again re-creates the gif interface.
After that to get traffic going i also have to edit and save the vip again.

Associated revisions

Revision 2de650f6 (diff)
Added by Ermal Luçi over 4 years ago

Fixes #4389 The VIP interfaces cannot be assigned since they are just an identification of the VIP for tracking. Consider that when configuring gif/gre. Also on bridges you cannot set a vip interface as its member.

Revision b65de558 (diff)
Added by Ermal Luçi over 4 years ago

Fixes #4389 The VIP interfaces cannot be assigned since they are just an identification of the VIP for tracking. Consider that when configuring gif/gre. Also on bridges you cannot set a vip interface as its member.

History

#1 Updated by Ermal Luçi over 4 years ago

Can you provide your config.xml to have a way to reproduce this normally it should work as expected!

#2 Updated by Pi Ba over 4 years ago

Ok, reverted a test vm to factory defaults, then configured a simplified setup again it shows the same problem.

Saving OPT1 interface from the webgui after booting makes it work.. (i can 'ping6 google.com' from pfSense console)

Its a tunnel using HE.net tunnelbroker.. (ive changed the ipv6 ip's 'aaaa:bbbb'..) Also the config was created on a virtualbox VM running on Windows7, and behind another modem that hands out dhcp leases in the 192.168.0.0/24 range.. All of that i don't think is relevant though.. The gif0 interface should be created under any circumstance.

#3 Updated by Ermal Luçi over 4 years ago

  • Status changed from New to Feedback

Ok should be fixed by the commit i pushed.
Can you please confirm as well?

This seems to be a bug since 2.1++

#4 Updated by Ermal Luçi over 4 years ago

  • % Done changed from 0 to 100

#5 Updated by Ermal Luçi over 4 years ago

#6 Updated by Pi Ba over 4 years ago

Copied interfaces.inc and system.inc to my 2.2 box and seems to work alright now..

Without daily snapshots online, what is the proper way to test changes from master git branch?

#7 Updated by Chris Buechler over 4 years ago

  • Affected Version changed from 2.2 to All

best to gitsync to get to 2.2.1 right now. Option 12 at console, run "playback gitsync RELENG_2_2"

#8 Updated by Chris Buechler over 4 years ago

  • Category changed from CARP to Interfaces
  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF