Project

General

Profile

Bug #4471

stf tunnel interface is not destroyed when 6rd or 6to4 tunnel is disabled

Added by Paul K over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
02/24/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

When you configure IPv6 to use 6rd or 6to4 tunnel a new interface ('wan_stf' for example) is created.
If IPv6 configuration is then changed to none, that tunnel interface is not being disabled. It will stay up until the system is rebooted.
If the whole interface is disabled stf tunnel interface does get removed

Associated revisions

Revision df966626 (diff)
Added by Chris Buechler over 4 years ago

Destroy stf interface when 6rd or 6to4 tunnel is disabled. Fixes #4471

Revision c0e5ab96 (diff)
Added by Chris Buechler over 4 years ago

Destroy stf interface when 6rd or 6to4 tunnel is disabled. Fixes #4471

Conflicts:
etc/inc/interfaces.inc

History

#2 Updated by Chris Buechler over 4 years ago

  • Category set to Interfaces
  • Status changed from New to Confirmed
  • Target version set to 2.2.1

#3 Updated by Chris Buechler over 4 years ago

  • Status changed from Confirmed to Feedback

Thanks Paul. I merged that, though had to do so manually because of whitespace changes in the mean time. leaving for feedback for now, if you can review the commits (which will be attached here in a few minutes) it'd be appreciated.

#4 Updated by Chris Buechler over 4 years ago

  • % Done changed from 0 to 100

#6 Updated by Paul K over 4 years ago

Tested a bunch of different scenarios on 2.2 branch. Enabling/disabling 6rd and 6to4, switching between 6rd<->6to4, enabling/disabling interface, etc. Everything appears to working correctly now. Thanks for applying the fix Chris.

#7 Updated by Chris Buechler over 4 years ago

  • Status changed from Feedback to Resolved

Thanks Paul!

Also seems fine here.

Also available in: Atom PDF