Project

General

Profile

Bug #4481

DHCP server - Dynamic DNS options layout messed up

Added by Kill Bill about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DHCP Server
Target version:
Start date:
03/01/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.1
Affected Architecture:
All

Description

Associated revisions

Revision 6b16c91c (diff)
Added by Phillip Davis about 5 years ago

Add missing BR tags and fix display with pfsense_ng_fs theme

Fixes #4481
Similar issue to commit https://github.com/pfsense/pfsense/commit/5cfd948144741ba0d6981f89b2e40257cb9ef2b1
Note: services_dhcpv6_edit.php - these fields are not present so nothing to edit/fix.

Revision bd5a8268 (diff)
Added by Phillip Davis about 5 years ago

Add missing BR tags and fix display with pfsense_ng_fs theme

Fixes #4481
Similar issue to commit https://github.com/pfsense/pfsense/commit/5cfd948144741ba0d6981f89b2e40257cb9ef2b1
Note: services_dhcpv6_edit.php - these fields are not present so nothing to edit/fix.

History

#1 Updated by Phillip Davis about 5 years ago

services_dhcp.php has not changed since 1 Jan 2015 so should be the same in 2.2
I do not see this problem in 2.2
What browser are you using?

#2 Updated by Kill Bill about 5 years ago

Apparently I was not specific enough. This is in the "DHCP Static Mappings for this interface." -- i.e., when you add a static lease. FF36, Chrome v42, IE11. All messed up. (Latest 2.2.1 snapshots.)

#3 Updated by Phillip Davis about 5 years ago

That made me update my home system to 2.2.1-DEVELOPMENT - time to be checking/testing with that anyway. From Firefox 31.5.0ESR I can add or edit static mappings, click the Dynamic DNS Advanced button and the fields all open out nicely like they should.
Tried on another laptop with Firefox 36.0 and I cannot reproduce the issue there either.

#4 Updated by Kill Bill about 5 years ago

Exact same messed up layout on multiple 2.2 nanobsd boxes. Dunno guys, but I can see obviously missing BR tags on lines 507 and 511 of services_dhcp_edit.php when you compare that with lines 1052/1056 of services_dhcp.php.

#5 Updated by Kill Bill about 5 years ago

#6 Updated by Phillip Davis about 5 years ago

Now I tries with psense_ng_fs theme and can see the problem. That is the different factor. The full screen width is making things like this seen, the text and fields that are missing "br" can actually be rendered on the same line.
Yes, it needs fixing. And you might like to open up lots of GUI pages with pfsense_ng_fs theme and see if there are other places where similar happens.

#7 Updated by Phillip Davis about 5 years ago

I made a pull request to fix that: https://github.com/pfsense/pfsense/pull/1535

#8 Updated by Phillip Davis about 5 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#10 Updated by Kill Bill about 5 years ago

Fixed, thanks. ;)

#11 Updated by Renato Botelho about 5 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF