Project

General

Profile

Actions

Bug #4502

closed

Default gateway not switching when interface stuck in pending state

Added by Bipin Chandra over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
Start date:
03/09/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

i have a full install box with 4 WANs and 1 LAN, the first 3 WANs and LAN work using VLANs and the last one using a different nic, the default gateway is the first WAN on the VLAN and fail over is set such that in member down case route out of WAN 2 on the VLAN. Suppose if the isp modem goes down on WAN 1 then pfsense apinger reports as pending and it wont switch the default gateway and at times LAN to wan traffic also wont fail over using the wans inspite of setting as member down or high latency and packet loss.

the main issue is the pending state of apinger, there needs to be a way such that in pending state also switch the default gateway or make fail over work or under gateway groups add another option called pending which would trigger exclusion of a member.

Actions #1

Updated by Bipin Chandra over 6 years ago

all the WANs are pppoe connections and this box is live on the internet with complete remote access using all WANs if any of the devs need to look into it

Actions #2

Updated by Chris Buechler over 6 years ago

  • Category set to Routing
  • Status changed from New to Resolved
  • Affected Version changed from 2.2 to All

it checked for status "down", rather than not up. Fixed. Thanks for the report.

Actions #3

Updated by Bipin Chandra over 6 years ago

thanks, works great now

Actions

Also available in: Atom PDF