Project

General

Profile

Bug #4537

Crash and reboot when accessing the web UI from the IPsec mobile client or over the tunnel on 32 bit

Added by Vadim Ginzburg about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
IPsec
Target version:
Start date:
03/19/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:
i386

Description

Accessing the WebUI while over the IPSec mobile connection will crash the box.
The issue was fist discovered on 2.2.
Forum thread https://forum.pfsense.org/index.php?topic=87946.0

pf-crash (1).txt (153 KB) pf-crash (1).txt Chris Buechler, 04/13/2015 10:13 PM

Associated revisions

Revision 05591613 (diff)
Added by Ermal Luçi almost 4 years ago

Fixes #4537 On 32bit platform do not enable direct dispatch on IPsec since it crashes the system

Revision 8b8a4630 (diff)
Added by Ermal Luçi almost 4 years ago

Fixes #4537 On 32bit platform do not enable direct dispatch on IPsec since it crashes the system

History

#1 Updated by Chris Buechler about 4 years ago

  • Subject changed from Crash and reboot when accessing the web UI from the IPsec mobile client or over the tunnel. to Crash and reboot when accessing the web UI from the IPsec mobile client or over the tunnel on 32 bit
  • Category set to Operating System
  • Affected Version set to 2.2
  • Affected Architecture set to i386

This is specific to 32 bit versions only, and something beyond that which hasn't been narrowed down yet, as it's not universal to all 32 bit systems. Nor is it hardware-specific.

#2 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Confirmed
  • Priority changed from Normal to High

Appears setting sysctl net.inet.ipsec.directdispatch to 0 (can be done under System>Advanced, System Tunables) fixes this issue.

#3 Updated by Chris Buechler about 4 years ago

  • Category changed from Operating System to IPsec

#4 Updated by Chris Buechler about 4 years ago

crash provided in duplicate #4610 attached.

#5 Updated by Chris Buechler almost 4 years ago

  • Target version set to 2.2.3

For 2.2.3, let's set net.inet.ipsec.directdispatch=0 where IPsec is enabled and running on 32 bit.

#6 Updated by Ermal Luçi almost 4 years ago

  • Status changed from Confirmed to Feedback

Done for non amd64.

#7 Updated by Ermal Luçi almost 4 years ago

  • % Done changed from 0 to 100

#8 Updated by Ermal Luçi almost 4 years ago

#9 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved
  • Affected Version changed from 2.2 to 2.2.x

that works around the issue. For tracking purposes we'll mark this resolved. I opened #4754 to investigate the root cause.

#10 Updated by Jim Thompson almost 4 years ago

  • Assignee set to Jim Thompson

Also available in: Atom PDF