Project

General

Profile

Bug #4604

NTP time server entries may or may not work, depending upon interfaces selected when configuring NTP service

Added by B. Derman over 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
NTPD
Target version:
-
Start date:
04/13/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.1
Affected Architecture:
i386

Description

The attached PDF (NTP.pdf) shows the following:

- 2 time-server entries: time.apple.com and another pfSense box (in that order)

- select both WAN and LAN interface OR select neither interface:
+ other pfSense box is always status "Unreach/Pending"
+ time.apple.com works

- select only LAN interface:
+ other pfSense box works
+ time.apple.com is always status "Unreach/Pending"

- select only WAN interface:
+ other pfSense box is always status "Unreach/Pending"
+ time.apple.com works

I didn't capture the screenshots, but if you reverse the order of the 2 time-server entries, it also reverses the working vs. "Unreach/Pending" status, given the same interface selection(s).

I have a multi-LAN, multi-WAN config with only the LAN interfaces selected and a single time.apple.com time-server entry, and that works fine.

Another simple LAN/WAN box also has only the LAN interface selected and a single time.apple.com time-server entry, and that works fine -- but on that system, the LAN interface appears first in the list ... so the bug appears to be associated with the order of the selected entries in the interfaces list.

(In the attached file, the single-digit at to top of the screenshot associates configs with status/results)

NTP.pdf (396 KB) NTP.pdf B. Derman, 04/13/2015 02:43 AM

Also available in: Atom PDF