Project

General

Profile

Actions

Bug #464

closed

Problems with setup wizard

Added by Chris Buechler over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/01/2010
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

There are a few issues with the setup wizard.

1. Most or all of the text box fields do not have the text offset, so it overlaps with the pencil icon in the box (example in 1.png)
2. The GMT offset zones (GMT+X, GMT-X), which are the opposite of what one would expect from their names, are shown. These are filtered out elsewhere in the web interface, and need to be here as well. (2.png)
3. Lacking input validation -
a) the General Setup page doesn't enforce valid hostname, domain, or DNS servers.
b) the Time Server Information page doesn't enforce a valid time server hostname
c) the Configure WAN interface page doesn't enforce valid MAC, MTU, IP, gateway, hostname, etc.
d) the Configure LAN interface page doesn't require a valid IP


Files

1.png (2.71 KB) 1.png Chris Buechler, 04/01/2010 01:51 PM
2.png (7.59 KB) 2.png Chris Buechler, 04/01/2010 01:51 PM
Actions #1

Updated by Ermal Luçi over 11 years ago

1 should be fixed by jimp commit to pfsense-ng theme.

Actions #2

Updated by Ermal Luçi over 11 years ago

  • Status changed from New to Feedback

This should be feedback.

Actions #3

Updated by Chris Buechler over 11 years ago

  • Status changed from Feedback to New

Valid MTU is still not verified. Didn't check other fields.

Actions #4

Updated by Jim Pingle over 11 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Chris Buechler over 11 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF