Project

General

Profile

Bug #4711

DHCP static mapping DNS servers do not override correctly

Added by Jeremy  99 over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
DHCP Server
Target version:
-
Start date:
05/18/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.2
Affected Architecture:

Description

1) On the DHCP Server page, enter 4 different DNS Servers. Make sure the first one is the pfSense LAN interface. For example:
192.168.1.1
2.2.2.2
3.3.3.3
4.4.4.4

2) Create a static mapping and enter the pfSense LAN interface (192.168.1.1) as the primary and only DNS server. Leave the other 3 boxes blank.

3) On the DHCP client computer, refresh its DHCP request.

4) Notice that the client still shows all 4 DNS servers from the DHCP Server page, not the 1 DNS server from the Static Mapping page.

Note: If you enter a DNS Server on the Static Mapping page OTHER THAN the LAN interface IP, it works correctly. For example, if you enter 2.2.2.2, the client will only get 2.2.2.2 as expected.

General Setup.png (21.7 KB) General Setup.png Jeremy  99, 05/18/2015 08:49 AM
LAN interface.PNG (27.8 KB) LAN interface.PNG Jeremy  99, 05/18/2015 08:49 AM
DHCP Server.PNG (27 KB) DHCP Server.PNG Jeremy  99, 05/18/2015 08:49 AM
Static Mapping.PNG (36.4 KB) Static Mapping.PNG Jeremy  99, 05/18/2015 08:49 AM
Client.png (20.7 KB) Client.png Jeremy  99, 05/18/2015 08:49 AM

History

#1 Updated by Jim Pingle over 5 years ago

  • Status changed from New to Rejected

Duplicate of #3915

It's a bug in ISC DHCP server, not our code. Supposedly will be fixed in a newer version of the daemon.

Also available in: Atom PDF