Project

General

Profile

Actions

Bug #4749

closed

DHCPv6 server not disabling after initial setup

Added by Andreas Peetz over 6 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv4)
Target version:
-
Start date:
06/07/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

Fresh install of pfSense 2.2.2 with 1x LAN and 1x WAN interface.
Used the console menu to (#1) assign interfaces and (#2) set interfaces IP addresses.
During (#2) disabled DHCP and DHCPv6 server on the LAN interface, but DHCPv6 server keeps starting after every reboot.

Service shows up as NOT enabled in the WebGUI, but the processes run:

# ps waux| grep dhc
dhcpd   31851   0.0  2.2  20724 10840  -  Is    9:26PM  0:00.00 /usr/local/sbin/dhcpd -6 -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpdv6.conf -pf /var/run/dhcpdv6.pid em0
root    32378   0.0  0.4   8316  1880  -  Is    9:26PM  0:00.00 /usr/local/sbin/dhcpleases6 -c /usr/local/bin/php -f /usr/local/sbin/prefixes.php|/bin/sh -l /var/dhcpd/var/db/dhcpd6.leases
root    50926   0.0  0.5  14664  2336  -  Ss    9:26PM  0:00.01 /usr/sbin/syslogd -s -c -c -l /var/dhcpd/var/run/log -P /var/run/syslog.pid -f /var/etc/syslog.conf

The dhcpdv6 section in config.xml looks like this:

<dhcpdv6>
<wan>
<ramode>router</ramode>
<rapriority>low</rapriority>
<rainterface/>
<radomainsearchlist/>
</wan>
<lan>
<ramode>managed</ramode>
<rapriority>high</rapriority>
<rainterface/>
<radomainsearchlist/>
</lan>
</dhcpdv6>

Found similar bug report in 2.1, but that was closed as not reproducable(?): https://redmine.pfsense.org/issues/3408

Actions #1

Updated by Andreas Peetz over 6 years ago

Also, ENabling and DISabling the service again in the WebGUI does not change the behaviour: The DHCPv6 server is still running and restarts after every reboot.

What parameter in config.xml is supposed to be changed when I disable the service?

Actions #2

Updated by Chris Buechler over 6 years ago

do you have an interface set to track for PD?

Actions #3

Updated by Andreas Peetz over 6 years ago

No, both LAN and WAN interfaces use static IPv6 and IPv4 addresses. IPv6 routing is done for a public /64 network (and works fine).
No prefix delegation used.

LAN - IPv4: 192.168.64.1/22
LAN - IPv6: 2a01:4f8:xxxx:7485::1/64

WAN - IPv4: 78.47.yyy.131/29, GW= 78.47.yyy.129
WAN - IPv6: 2a01:4f8:xxxx:7485::ffff/128, GW= fe80::1

I was not able to set this WAN IPv6 config during the initial setup at the console (input was not accepted). I chose 2a01:4f8:xxxx:7485::ffff/127 and GW= 2a01:4f8:xxxx:7485::fffe there and changed it later through the WebGUI.

Actions #4

Updated by Chris Buechler over 5 years ago

  • Status changed from New to Duplicate
  • Affected Version deleted (2.2.2)

duplicate of other that was fixed in 2.3.x

Actions

Also available in: Atom PDF