Project

General

Profile

Actions

Bug #4868

closed

excessive Quagga package restart when IP change

Added by Xavier Romain about 7 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Quagga OSPF
Target version:
-
Start date:
07/22/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

Already mentioned on this thread one year ago :
https://forum.pfsense.org/index.php?topic=80262.0

Quagga/OSPF services must NOT restart when IP change is detected to avoid 1) losing whole routing table and 2) blocking all other networks during restart phase.

Actions #2

Updated by Xavier Romain about 7 years ago

Fantastic! Works fine. Thanks.

This patch will it be implemented in a future release?

Actions #3

Updated by Chris Buechler about 7 years ago

  • Project changed from pfSense to pfSense Packages
  • Subject changed from Quagga package restart when IP change to excessive Quagga package restart when IP change
  • Category changed from Routing to Quagga OSPF

the issue will be addressed at some point. The complication is you can't just not restart in that circumstance, as there are a variety of situations where that would break things (binding to dynamic interfaces for instance). It needs much more logic about when to restart and when not to. In the mean time, for those who don't need it to restart, that patch is the answer. It's not committed because it'll break things for other people's circumstances.

Actions #4

Updated by Chris Buechler over 6 years ago

  • Status changed from New to Duplicate

duplicate of #4474

Actions

Also available in: Atom PDF