Project

General

Profile

Actions

Bug #493

closed

Checkboxes saved outside of setup wizard do not show checked in wizard

Added by Erik Fonnesbeck over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/09/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

The setup wizard does not properly display checkbox settings where the configuration setting is just set, but not assigned a value, if the setting was saved outside of the wizard. For example, if the DNS allow override setting is enabled during the setup wizard, the configuration looks like this and will show as checked when you go back to the wizard:

<dnsallowoverride>on</dnsallowoverride>

However, if you save the settings in System: General, it will look like this and will not show as checked in the wizard:

<dnsallowoverride/>

Both are valid ways to enable the setting, but the wizard does not properly handle the latter case when displaying the settings.

Actions #1

Updated by Ermal Luçi over 11 years ago

  • Status changed from New to Feedback

Patched.

Actions #2

Updated by Erik Fonnesbeck over 11 years ago

This is still an issue with latest code.

Actions #3

Updated by Chris Buechler over 11 years ago

  • Status changed from Feedback to New
Actions #4

Updated by Ermal Luçi over 11 years ago

  • Status changed from New to Feedback
Actions #5

Updated by Erik Fonnesbeck over 11 years ago

  • Status changed from Feedback to Resolved

It seems to be fixed now. I tried enabling/disabling it on either page and both now show the correct enabled or disabled state regardless of which of them enabled or disabled the setting.

Actions

Also available in: Atom PDF