Project

General

Profile

Bug #5016

CARP VIP issues - firewall_virtual_ip_edit.php

Added by Chris Buechler about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
08/26/2015
Due date:
% Done:

100%

Estimated time:
Spent time:

Description

1) can't edit them, end up with "This IP address is being used by another interface or VIP." Check 1.2.3.4/32 on your test VM for one example
2) VHID isn't being saved, just end up with <vhid/>

Associated revisions

Revision 4d843977 (diff)
Added by Jim Pingle about 4 years ago

Fix incorrect variable references for CARP VIPs. Fixes #5016

Revision 2554dd64 (diff)
Added by Jim Pingle about 4 years ago

Fix incorrect variable references for CARP VIPs. Fixes #5016

History

#1 Updated by Steve Beaver about 4 years ago

  • Subject changed from CARP VIP issues to CARP VIP issues - firewall_virtual_ip_edit.php

#2 Updated by Steve Beaver about 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Looks like a pre-bootrap bug:
Line 270~ish

$vipent['vhid'] = $_POST['vhid'];
$vipent['vhid'] = $_POST['uinqid'];

should be:

$vipent['vhid'] = $_POST['vhid'];
$vipent['uniqid'] = $_POST['uniqid'];

Needs fixing on master too.

#3 Updated by Jim Pingle about 4 years ago

Actually that should be "uniqid" and not "uinqid" -- looks like a copy/paste line with one missed edit and one typo.

#4 Updated by Jim Pingle about 4 years ago

  • % Done changed from 0 to 100

#6 Updated by Jim Pingle about 4 years ago

  • Status changed from Feedback to Resolved

Saving CARP VIPs appears to work OK now.

Also available in: Atom PDF