Project

General

Profile

Bug #5022

creating CA doesn't actually create the CA

Added by Chris Buechler over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
08/26/2015
Due date:
% Done:

100%

Estimated time:
Spent time:

Description

system_camanager.php, "add new", create an internal CA. fill in the fields, click Save. No CA is added.

Associated revisions

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler
  • Target version set to 2.3

Programmer had set form action to GET when logic uses POST.

Page now creates CAs although I sometimes see:

openssl library returns: error:0D07A098:asn1 encoding routines:ASN1_mbstring_ncopy:string too short

depending on the country chosen. (US => error, GB => no error) Please advise.

#2 Updated by Jim Pingle over 3 years ago

Country code drop-down should be using the country code as the value, seems to be numeric now, so any of the 0-9 choices probably fail. GB passes because it's later in the list. The drop-down is new, it used to be text entry.

#3 Updated by Jim Pingle over 3 years ago

Opened #5043 for that separate issue with the drop-down.

#4 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Assigned

When pressing Save, the screen stays on "system_camanager.php?act=new" rather than returning to the CA list. The CA is added properly, it just doesn't redirect away after as it should. The redirect is OK when creating a certificate.

#5 Updated by Steve Beaver over 3 years ago

  • Status changed from Assigned to Feedback

return to calling page was commented out. Presumably for debug

#6 Updated by Steve Beaver over 3 years ago

  • % Done changed from 0 to 100

#7 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

Looks good now, thanks!

#8 Updated by Chris Buechler almost 3 years ago

  • Affected Version set to 2.3

Also available in: Atom PDF