Project

General

Profile

Bug #516

Auto update doesn't work on embedded

Added by Chris Buechler over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Upgrade
Target version:
Start date:
04/16/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

The auto update doesn't work with embedded. It needs to be able to differentiate between sizes. Or possibly don't show it on nanobsd and push this off to 2.1.

History

#1 Updated by Jochen Becker about 9 years ago

similar ticket #457
the general problem of upgrading a nanobsd pfsense installation
i think it can be fixed after #457 is fixed

and by the way it will be nice if the autoupdate funktion can be disabled if no url is given or the url is wrong
currently it says it will be a newer version online 8_0/... and i have installed the latest snapshot

#2 Updated by Jim Pingle about 9 years ago

Not quite, the case of embedded is a bit more complex than that. It has nothing to do with that other ticket.

#3 Updated by Jim Pingle about 9 years ago

  • Status changed from New to Feedback
  • Assignee set to Jim Pingle

After the next snapshot builder run, auto update should be possible on NanoBSD/embedded. You will need to update once more manually to the next available snapshot (Will be from late on June 21st or Early June 22), but subsequent updates should be possible automatically.

#4 Updated by Jochen Becker about 9 years ago

i have installed pfSense-2.0-BETA3-4g-20100623-1544-nanobsd-upgrade.img.gz
and selected
http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/.updaters/
as update url

and the detection works, the system said to me, ia m on the latest
i will wait since there will be a new 4G nano version

#5 Updated by Jim Pingle about 9 years ago

  • Status changed from Feedback to Resolved

There have been many positive success reports between here, the forum, and IRC. It seems to be working well now.

#6 Updated by Jochen Becker about 9 years ago

it works very very fine thanks a lot, but ... a little Detail

if you start the upgrade process and the file is downloaded you only get the message, system will reboot when upgraded.
you see a different page (https://<ip>/system_firmware_check.php) than on all other pages.
with details of the upgrading procedure (e.g.versionnumbers) and it is possible to click on "invoke upgrade"
it you click invoke upgrade or anywhere else in the menu you will get the nice animated harddisk on the page with the information system is upgrading.

so my detail, may it be possible to have only one page (the nice animated one) with the version numbers and make the "system_fimrware_check" page unavailable while upgrading? or just have a link to this specialpage, because you only can reach it if you know the page name, it is not possible to reach it while system is upgrade via the menu

#7 Updated by Jim Pingle about 9 years ago

If you want to open a separate ticket for that, that would be better. This ticket was about the update not functioning at all, what you suggest would be at the very least a different bug, and arguably a new feature.

#8 Updated by Chris Buechler about 9 years ago

Yeah this is closed and won't be reopened. Either open a feature request (which will be for post-2.0) or submit tested patches to implement that, in the latter case we can get it into 2.0.

#9 Updated by Jochen Becker about 9 years ago

new feature ticket opened as #697

Also available in: Atom PDF