Project

General

Profile

Bug #517

Do not check gateway within interface's IP subnet for dynamic gateways

Added by Chris Buechler over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Gateways
Target version:
Start date:
04/17/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Dynamic gateways are occasionally (almost always with PPP and PPPoE) outside of the subnet of the interface IP. The input validation on System>Gateways>edit gateway doesn't allow changing the monitor IP because it sees the gateway IP as invalid. For dynamic gateways, the input validation for gateway IP within interface IP subnet must be removed.

Associated revisions

Revision c6d1c7de (diff)
Added by Ermal Luçi about 9 years ago

Ticket #517. Fix saving of monitorip in dynamic interface cases.

History

#1 Updated by Jim Pingle about 9 years ago

It seems like storing the actual gateway IP for a dynamic WAN type may not be what we want to do anyhow, so it doesn't really make sense to validate against it. Or is this IP listed on this screen only for show?

#2 Updated by Chris Buechler about 9 years ago

Yeah it doesn't actually store it, it's only for show.

#3 Updated by Jim Pingle about 9 years ago

If that's the case then perhaps when this bug is fixed that field should be disabled (grayed out, not removed) for dynamic gateways.

#4 Updated by Chris Buechler about 9 years ago

It is grayed out, but it's still checked against the input validation.

#5 Updated by Ermal Luçi about 9 years ago

  • Status changed from New to Feedback

I fixed a problem of saving the monitor ip to the correct place in config.
Otherwise i was unable to reproduce this.

Please attach the relevant interface and gateway config parts to reproduce it.

#6 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF