Project

General

Profile

Actions

Bug #5298

closed

gitsync screws /tmp permissions

Added by Kill Bill about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/12/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.2.5
Affected Architecture:
All

Description

Upon running playback gitsync RELENG_2_2 from the developer shell, /tmp gets chmod-ed to 0755 instead of 01777; needless to say this breaks things badly.
Actions #1

Updated by Chris Buechler about 6 years ago

  • Status changed from New to Confirmed

gitsync itself hasn't changed in RELENG_2_2 since pre-2.2.0 release, but something it's calling has, confirmed /tmp permissions change.

Actions #2

Updated by Renato Botelho about 6 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Kill Bill about 6 years ago

Thanks; did run gitsync twice and the permisssions went back to 01777.

P.S. Regarding "PHP chmod() doesn't like 1777" - yeah, the chmod() function has been written by the only idiot in the world who sets the permissions in decimal.

Actions #5

Updated by Chris Buechler about 6 years ago

  • Status changed from Feedback to Resolved

fixed, thanks

Actions

Also available in: Atom PDF